Multiple soft reset failures

How can I reach a person at Customer Service? I have had no reply to two outstanding case numbers. Multiple soft resets have failed with the error message "Corrupt database found." Soft resets previously enabled the successful restoration of backups. The two outstanding case numbers deal with those incidents. Soft resets now fail every time, and the hub does not work.

Welcome to the Hubitat forums!

They have recently changed the process to file a support case. I wonder if you fell into a "black hole" of sorts in this transition.

I will tag @support_team for you, they should get in touch with you probably first thing in the morning.

I don't know if we can help with this as a community, but maybe describe what led you to do the reset in the first place? Were you seeing some problem?

Is this error happening upon restoration, or during the initial reset steps?

And you [did] or [did not] download a backup before resetting? Or did you rely on the backups on the hub itself? Either way should work, but downloading a copy might help if you have one available to restore at some point.

You appear to be a new user, did you have much or anything on the hub for devices and apps? If you don't have much on there, it might be easier to start from scratch, which would require support to walk you through that full reset process.

1 Like

Try a full power cycle before a soft reset. I've seen a few cases where something in the file system gets locked up and only full power cycles frees it up. It's rare, but it happened before.

If that doesn't help, please PM me your hub's id, and I'll take a look.

1 Like

Thanks for your reply. My Hub ID:

Your suggestion to "Try a full power cycle before a soft reset" worked this morning but failed last night. See the sequence of my latest episode at the end of this email.

The case numbers that remain unanswered are 26029 (4/14/22) and 26081 (4/18/22).

The soft reset procedure presents the option of either restoring a previous backup or starting from scratch. The fresh start option sometimes works. Not so the more direct approach.

Note also that soft reset most commonly fails with either the corrupt database message or a failure to connect message. This seems puzzling. What database is there to corrupt in the case of a fresh start?

The record of automatically generated backups suggests when the most recent failure occurred. "2022-05-12 03:02:29 AM EDT" size = 0. The subsequent "2022-05-12 10:19:00 PM EDT" size nearly doubles that of the earlier valid backups.

Thank you for any assistance you can provide to resolve this chronic problem.

2/16/22: post at community website recommends validating backups by performing a soft reset and restoring the backup made immediately beforehand.

validated backup: Challisford_2022-04-16_2.3.1.139.lzf
(validation procedure: restore succussfully immediately after creation)


corrupt database
soft reset
upgrade to version from
upgrade froze at 65%
tool resumed "Checking For Update"
soft reset
setup became unresponsive
soft reset
second upgrade attempt
"Corrupt database found" (despite fresh install)
reboot after power off
soft reset
third upgrade attempt
fail: "This site can't be reached"
Diagnostic tool reports version
but system reports: "Corrupt database found" (despite fresh install)
soft reset
failed: "Corrupt database found"
soft reset
failed: "Corrupt database found"
soft reset
failed: "Corrupt database found"
power off overnight
power on: "Corrupt database found"
soft reset
successful bare hub
restore validated backup Challisford_2022-04-16_2.3.1.139.lzf

Thank you for your reply. Staff gopher.ny offered to take a look this morning.

In answer to your questions:

Hub failure, indicated by either a failure to connect or a corrupt database error message, occurs sporadically. It first occurred during the initial setup. It then occurred whenever updating the hub firmware. It now occurs at random. Hours, days, or weeks may pass between failures.

The option to restore immediately after a soft reset has always failed. The blank slate option after a soft reset usually fails but has so far always succeeded eventually. The restoration of a validated backup after a successful blank slate soft reset usually works.

Restoring from any of the five automatically generated backups usually fails. I now validate backups by immediately restoring a downloaded file.

Thank you for your suggestions

1 Like


Uh not sure you should be exposing your HubID on these forums like that. Not that it really makes a difference I guess but like other seemingly inconsequential info generally a good security practice not to. Usually the better way is by sending it via a Personal Message (PM) to the person directly.

1 Like

Soft Reset is only good to get your hub back online, however, if the problem that caused the database corruption in the first place is not addressed, it's only a matter of time before the database ends up corrupted again. Please review your Logs for suspicious activity as soon as you perform the Soft Reset, and disable and/or remove any offending custom apps or devices that may cause problems.

PS I flagged your post above because it reveals personal hub identification. You may want to remove the HUb ID from your post.


Done that before. Nothing obvious to me, but I'll try again. Meanwhile, please elaborate on your comment "Soft Reset is only good to get you back online." Are you saying that a soft reset does not return the hub to a factory-fresh configuration? My hub fails when performing a firmware update immediately following a successful soft reset. Database corruption should not play a part in a factory-fresh configuration. If a soft reset does not purge the database, how can I do so?

Thank you.

Downloading a backup creates a "cleaned" database that should be glitch-free.

Soft reset allows you to erase your current hub database...apps, configurations, automations, etc., are all gone. Radio (Z-Wave/Zigbee) info is retained.

When you restore a saved database you restore your apps, settings, automations, etc., and are then up and running w/a (hopefully) clean database and your existing radio info.

Only a full reset (generally never do unless advised by support) will get your entire hub (apps, devices, automations, settings, Z-Wave and Zigbee radios) back to factory default. If you do that you will have to re-do everything including re-joining all devices to your hub.

1 Like

This is really odd...there should be no difference between a manually created backup and one from the automated backups. Really strange results.

What do you mean when you say "fresh start?" Can you describe what you are doing when you try to do a fresh start?

1 Like

Sure, after a Soft Reset your database is functional, but if you restore the same app or device that has caused the problem in the first place, then it's a matter of time before you end up in the same situation.

Support would assist you in that. A full reset obliterates everything and restoring your database would NOT restore your radios so you would have to reset and re pair each and everyone of your devices as well as re register the hub. This is a thing of last restort.

All "Soft Reset" does, is remove the database and installs a new one in its place. Are you saying that you don't see the "Get Started" screen following a soft reset, before restoring a backup?

Based on details provided above, the last attempt to Soft Reset worked and you restored a backup. Please disable any custom integrations you may have previously installed to see if that resolves the problem. Then you can add the custom integrations one by one to identify which one is causing issues. If your hub continues to have problems with all custom integrations disabled, please come back here and let us know so we can further investigate.

1 Like

Disabling Apps (or drivers) is very easy BUT it's default hidden...

On your Apps page, in the upper right corner is a dim X... click it, it shows red:
Screen Shot 2022-05-13 at 12.51.12 PM

That will expose a column to the left of every app. Click those boxes to disable, individually, each Custom App.


@user409 To add to what @bobbyD said, For now, for each change you make download a new copy of your backup to your PC. This way you know you have a clean database.

1 Like