Motion Sensor not turning on switches

I'm having trouble with the motion sensors not turning on the light switches. It was working a couple of days ago, but now nothing its automatically turning on due to the sensors. Its showing motion when we walk through them. Would a back up and restore be a good idea to restore functionality? Any help is appreciated.

You need to provide some more information about how you have the motion sensors controlling the lights.
There are multiple ways to do this and your method will have unique solutions versus other methods.

1 Like

So unfortunately, my dad was the one who set it all up and he passed away recently. I can show you the way he was controlling the sensors below. It's been working for all this time, but it stopped working yesterday. I did restart the router yesterday so I'm thinking that might have broken it? I'm able to press the button on the dashboard and turn on/off the light.

What are the triggers for this rule?
The rule is quite complex for what it does.
You might find it easier to pause this rule and create a couple of simple rules using the built-in Motion Lighting app.

So these are the triggers for the rule.


I tried making a simple rule to turn on the lights but it doesn't seem to be working either. Here's what I put below.

I'll try to create a rule with the built-in motion lightning app and get back to you.

Since you triggered on motion activation, try removing the redundant if statement.
Also check the logs for more information.

Thanks for the help! I was able to get my light working with the built-in motion lightning app! I also had to go to the right hub to fix it. My dad had set up two c7 hubs, one called apps and one dev. It wasn't working originally in the c7Apps HE, but I tried creating a rule in the c7Dev HE and that light started flickering.

My condolences.


Download the Hubitat app