Motion Lighting with Mode not running properly

Hi,

Platform: 2.3.1.142
Hardware: Rev C-5
Motion Lighting version: 1.6.2 (4/6/2022)

Configurations:

Initial condition: no motion detected + lifx light is OFF

When I made the movement in the study area, the lifx light is not turning on; the following is the log from the motion lighting:

Not turning on, already on

When I tried to run the scene manually, lifx light turned on just fine

What do you think could have happened here?

Thank you

A few thoughts. Motion Lighting cannot accommodate your initial condition, it will only be triggered by the motion event. However, the app is optimized so that it doesn't generate unnecessary commands if the light is on. The log entry you pointed out is one such optimization. The device simply reported as being "on," at the time when the motion was triggered (in your case, the scene device). You can validate this by looking at Device Details page. I am 100% certain that your (scene) device switch status is showing as "on".

I thought this was an option you had to choose?

No, it's the other way around. You have an option to disable the optimization.

Got it, thanks.

Thanks for your reply @bobbyD
Sorry, I should have clarified, my condition is motion event only.
When motion is detected, the lifx light should run the scene, based on the mode of the day.

I've tried to record this here; hopefully this clarifies the issue I experience:

  • Window left is the motion sensor
  • Top and Bottom Middle windows are the scene app
  • Top right window is the lifx device itself
  • Bottom right window is the log

Thank you

Hi @bobbyD, could I please get an update on this matter?

If you prefer me to raise a support case, please let me know

Thanks

You are looking at the wrong device in your YouTube video. Your rule uses the scene device, not the Study-Filx device. That Lifx device is off, but the scene device you are using in your rule is "on" (Study-Lifx-bright device for the original example while your mode was "Evening"), based on what the app sees, that's why you are getting the "not turning on, already on" message.

Thanks for your reply

Are you saying that in the video, for the middle windows, instead of showing "scene devices" (from devices menu), I should show the "scene" (from app menu) itself?

No, in the upper right, you should be looking at scene activator device from Devices page, not the Lifx device.

Here is an example of a scene named as your evening scene (the switch is "on", so the rule will not run):

To be honest, you are complicating yourself by creating a scene if all you do is setting color and brightness (level) to one Lifx device. You could define the color and level in the Motion Lighting for the Lifx device. Scenes are great if you adjust different devices at the same time, and even then, I personally prefer doing it in the app directly, specifically to avoid the confusion you are running into.

Thanks for your response!

I have re-recorded the session again, this time around with the Device > Scene being shown in the middle: here

As you can see, both scenes are OFF when motion is detected.

One of the reasons I use scene is because the setting is not only used by motion lighting, but also rules too; by having scene, it'll be easier for me to maintain it (rather than I need to go through multiple rules, motion lighting, etc)

Thanks

Hi @bobbyD

Just wanted to check whether you had a chance to look at the updated video as yet? Thanks

Download the Hubitat app