Motion Lighting Rule - Transition stops before Level 100

I upgraded from 2.2.6 to 2.2.8.156

On 2.2.6 my Motion Lighting rules worked flawlessly.

However as of 2.2.8 the lights turn on but not to full brightness. In some instances it seems they make it to 100 but then dim back down.

I have completely removed the Motion Lighting App and recreated all the rules.

I can manually set the level to 100 on the bulbs with no issue.

Bulbs are Sylvania Lightify RGBW A19 bulbs.
Drivers: Generic ZigBee RGBW Light
Data From a Bulb:

  • endpointId: 01
  • model: A19 RGBW
  • application: 01
  • firmwareMT: 1189-0019-00102428
  • softwareBuild: 00102428
  • manufacturer: LEDVANCE

Logs:
08-25 04:06:28.027 pm [info] Light_Kitch_RGBW_02 was turned off
08-25 04:06:27.931 pm [info] Light_Kitch_RGBW_01 was turned off
08-25 04:06:26.833 pm [info] Turning off lights
08-25 04:05:26.781 pm [info] Delaying off for 1 minute
08-25 04:05:26.739 pm [info] Motion inactive MSensor_Kitch
08-25 04:04:51.890 pm [info] Light_Kitch_RGBW_02 set to 75
08-25 04:04:51.833 pm [info] Light_Kitch_RGBW_01 set to 63
08-25 04:04:51.679 pm [info] Light_Kitch_RGBW_02 set to 46
08-25 04:04:51.554 pm [info] Light_Kitch_RGBW_01 set to 34
08-25 04:04:51.500 pm [info] Light_Kitch_RGBW_02 was turned on
08-25 04:04:51.358 pm [info] Light_Kitch_RGBW_01 was turned on
08-25 04:04:50.914 pm [info] Setting colorTemp [Light_Kitch_RGBW_01, Light_Kitch_RGBW_02] to 6500 at level 100
08-25 04:04:50.878 pm [info] Motion active MSensor_Kitch

Looking at the device the last level reported in the log is what they are at.

Any assistance would be greatly appreciated.

Thanks in advance.

Did you switch drivers at any point?

Did you try the newer Advanced Zigbee drivers (and hit configure)? I find they work good with this bulb.

And do you have a transition time set for this in the device's settings page? Maybe that changed somehow?

Another plug for the advanced driver, it has lots more choices for transition time including ASAP which is nearly instant. And it has 6 separate settings for transitions like on, off, color, level, and so on instead of the one overall setting like the driver you are using.

Changing drivers to "Advanced Zigbee RGBW Bulb" and hitting configure fixed it.

Thank you so much. I've been banging my head for days on this problem.

FYSA, the only changes were upgrading Hubitat firmware and adding an new bulb when this started. I did try different transition times at the bulb level to see if that helped with no success.

Download the Hubitat app