Motion Lighting app turns on scene but does not turn it off after delay

I have a scene (Scene-1.2 / Version 1.4.7 (11/25/2021)) which turns on 4 lights. Activating the scene from the Scene app works.

I've set up a Motion Lighting app (Version 1.5.9 (11/22/2021)) which turns on the scene between two times, and this also works - the scene turns on when motion is detected by the motion sensor.

But then I've set the option to Minutes to delay before turning off to 1, but this is not working - the lights all stay on after one minute. Once the motion sensor reports inactive, I do see the Delaying off for 1 minute from the app in the logs, and then one minute later I see Turning off lights but the lights don't actually turn off.

I'm on hub Rev C-7 / version 2.3.0.119 but this actually did start happening before I'd upgraded to 2.3.0.x.

Any ideas?




I assume that the scene’s controlling device is able to turn on and off the devices? Do they sometimes not turn on or off?

I’m wondering if the devices are actually getting the commands… What protocol do they use? (Z-Wave, Zigbee, etc.)

If Z-Wave, I would recommend trying to enable metering as this will add a delay between the commands which could help.

If memory serves me correctly "deactivating" the scene does not turn off the lights. You have to tell motion lighting what individual lights to turn off. I know that's how I have my ML apps set up that uses scenes to turn on lights and they work.

1 Like

Three of the devices in the scene are Philips Hue Zigbee (not bluetooth) devices using the Hue Bridge Integration app, and the fourth is a CentraLite outlet using the Generic Zigbee Outlet driver. I've never had connectivity/reliability issues with these devices, nor have they not all turned on properly when this particular scene is activated. The only issue is that none of them turn off.

As for the scene's "controlling device", I don't have one, it's really just the Motion Lighting app I showed above which turns it on, and I assumed the lights in the scene would be turned off by the Motion Lighting app. Like what @oldcomputerwiz mentioned above - scenes being deactivated is not meant to actually turn off the lights in a scene, and you'd have to specify the lights to be turned off. I'd lean towards not doing this, in case I change the devices in a scene, I'd have to also go update the ML app.

I've got a working solution in place now - I've created a Virtual Switch device, and then two Basic Rule rules: when the virtual switch turns on, turn on the scene, and when the virtual switch turns off, turn off the scene. Then I've updated the ML app to control the virtual switch instead of the scene.

I'd be interested to hear if there's a more efficient way to accomplish this, but I'm happy with my solution for now. Thanks both!

1 Like

In the Motion and Mode Lighting app there is a setting that allows additional switches to be turned OFF when motion inactive. I use this feature to turn OFF the virtual switch (scene activator) automatically created by the Groups and Scenes app, which works very well for me.

1 Like

This works for me too. And the beauty of using the Activate Scene is that all manual level or on/off overrides just work. Dont quite understand how though. ML must capture all scene devices settings and compare to manual adjustments. Very elegant because you can keep your scene definition in the scene, only. Using ML to define the scene instead is not very practical because ML cannot manage multiple dimmer levels so since I have that in my scenes you need a lot of child apps and it gets cumbersome to manage.

This is sort of a hidden gem. Scenes per mode is quite powerful given that each Scene is its own collection of devices and settings for them.

Download the Hubitat app