Motion Lighting App: How to switch off lights manually and have the ML app register light as off

Hi all,

I've just recently got the HE C-5 Hub and moved all my smart devices from SmartThings V3 over to the HE hub. One of the first things I tried is to setup a ML app automation that uses motion sensors to turn on/off lights in the closet. I find that if i don't touch the light switches at all, the automation will run correctly, meaning that it would turn ON the light as soon as it senses motion and turn OFF the light at the preset delay before off time (I set it to 2 mins).

The problem is, as soon as I manually switch off the lights, wait for the motion sensor clear delay (30sec), and then I wave at the motion sensor again, the automation to turn ON lights would NOT fire off.

To have it working again, I would have to wait for the 30sec motion clear delay PLUS the 2min delay before off time to run it course (total of 2min 30sec) before the automation will work again.

Now, I've done some research and according this post its most likely due to the fact that ML apps does not know the current state of the light if I've turned off the light switch manually. I've checked the log and see that it is in fact showing "Not turning on, already on" despite light switch being turned off manually.

Following the instructions of previously mentioned post, I've added the closet's light swtich to "Switches to turn off lights" to ensure that the ML app is aware that the switch has been manually turned off and update its status accordingly. However, after many attempts, it has behaved the same as it were before. That option to set the "Switches to turn off lights" seems to not have any effect on getting the ML App to register the switch as being turned off. The log still giving "Not turning on, already on" message as I wave at the motion sensor.

Can any tell me if i've somehow configured it wrong? How do i have the ML app to register the light as being off when i turned off the light switch manually?

Any help is greatly appreciated !

HE C-5
GE Enbrighten Z-Wave Plus Switch 14291
Zooz Motion Sensor ZSE18

When you say you turn the light off manually, are you meaning you use the GE switch mentioned in your post? Might be worth posting a screenshot of the ML setupnifvyou can.

Was my issue similar to the issue you are having?

On the device page does the light show it is off if manually switched off?
I just tried this out with my rules and they were detecting that the lights were turned off manually.

Are you using the “generic z-wave smart dimmer” driver? If you are not using the smart driver, it may not report state change back to the hub. You might also try hitting “configure” on the device page.

Yes turning off the light manually means i physically tap the GE switch to turn it off.
Here is the screen shot of the ML app.

Not really the same Im using the GE on/off switch, yours is the GE dimmer

Yes, on the device page it does in fact show it current state is OFF when i turn the switch off manually.
I think the issue is that the ML app does not know that its OFF. For some reason ML app and the device list is not in sync with each other

When i first paired it to the hub it shows that its using the Generic Z-wave Smart Switch driver, but I've immediately changed the driver to the GE driver from the dropdown menu and hit the Save Device button.

I have not tried using the switch with the Generic driver.

I also have not tried hitting Configure on the device page. Maybe i'll give it s shot.

This may be a bug. I haven't tried this in a while since most of my lights are activated with button controllers, but remember having issues with it not working as expected when the light being controlled is the same as the on/off switch. Try creating a group with the lights you want to control, replace the lights in the app with the group, then see if it works.

I believe that driver is for the newer switch that doesn't have the breakaway tabs on the sides. If that is your device, then great, but you need to hit configure when you change drivers for the device to be configured properly.

1 Like

Sounds like there are people here more familiar with this than me and can offer a few suggestions that seem like they're worth checking out.

This fixed it for me!! I was using the wrong drivers the entire time!! Who would have thought picking the GE driver would be a wrong choice lol

Thanks a ton for the help !! Greatly appreciated!!

1 Like

Glad to hear it's working for you.