Motion lighting app challenges specific to Caseta

For some reason, I can get the Motion App to trigger different lighting settings per mode (using Casita), but if I try to do Scenes per Mode, they won't trigger. I can trigger the Scenes all individually, I can see the Motion Sensor activating, but I can't get the Motion to trigger the Scene. I tried to attach a screenshot, but it seems like I haven't posted enough for the forum to allow media. What step could I be missing here or is this a bug?

I just noticed something else. Now it doesn't seem to be working when I trigger a dimmer directly within the motion app either. In the logs, I notice two things. First, the motion app still shows as Paused, although I've Restarted and pressed Done both within that app and the master app. Also, it shows that the dimmer is "Not turning on, already on"... but the dimmer is off. Trying to add a screenshot, but still not allowed

I just figured it out. Had to completely delete the app and start from scratch. Seem to be a lot of issues like this. Not sure if this is caching our something else. Seems a bit kludgier than I was expecting. Is this everyone else's experience or is there something with my setup I might need to look into?

Now it's not working again. Can anyone point me towards a good video or resource for troubleshooting my routines?

In my early days with Hubitat, I found that searching the forum and asking questions worked well.

Are you getting errors in your log? If so, please post screenshots.

Also, it helps if you can post screenshots of your rule. That will help others help you.

1 Like

Thanks Sabastien. I've been trying, but the system hasn't allowed posting of screenshots or videos. Reading other posts, I think this is because I'm new and I just saw that I "earned Basic" with the last post, so hopefully that changes now. I think I have more information on specifics now, so I'm changing the title of the post

As mentioned, I'm using Caseta switches and dimmers, building one scene per area / mode and triggering those with motion sensors in the motion app. Sometimes these seem to not trigger. In the log, I'm seeing a lot of "Not turning on, already on". I found a lot of forum posts about this, which helped a lot, but lead to two points of confusion.

One of the scenarios where it doesn't work as I expect is when I turn the lights off manually and then they won't re-trigger. This probably happens way more often during testing than usage. I know the caseta buttons aren't available in Hubitat except for the Pico (and in most cases, I'm not pressing a Pico). I also realize I'm triggering scenes with motion. In both cases, my understanding is that I'm changing the values of the actual dimmer / switch, which will then be "known" by the motion app. Is there something that I could look for when turning off the lights at the switch to reset the timeout to that it will trigger again on the next motion sensing event?


The other thing that I've noticed with this programming is that in one room when I walk into a space, there is a time delay before the lights turn on, while in another room, when the trigger happens, the lights suddenly jump full on then jump to the proper scene settings after a second. Not sure if either is related to the fact that I'm triggering scenes or if I should be triggering an "off" scene after timeout.

This is the first time I'm able to post screenshots, so let me know if there is specific information someone would need to help understand my issue. Maybe I need to test each specific issue and post log files of those exact actions, etc...

I rarely use the motion lightning app, but at first glance, it looks like these should trigger.

Is there a reason why you trigger a Scene instead of individual lights? This introduces another possible failure point. For your initial testing, I would recommend using devices directly to see if the issue is with the rule or if it is with the scenes.

Are the sensors all the same? Some sensors “react” faster than others. Users report that Zigbee are faster than Z-Wave.

The light going to full first is something that some but not all Casseta dimmers do. I have a lot of them and one of them does this, but the others don’t seem to. I haven’t looked into it… It could be Hardware/Firmware dependent, it could depend on the load on the switch, it could be something else…

Thanks Sebastien. I'm using all the same sensor. They are Nyce NCZ-3043-HA ZigBee Ceiling Motion Sensors. I may swap out several soon though, because they are triggered by our cats and I don't think the sensitivity can be adjusted.

Using scenes to try and make it easier to update the looks consistently, without having to dig into multiple places.

Thanks for letting me know about the Caseseta going to full. That seem likely and will probably keep me from pulling me hair out looking elsewhere. I like the Casseta stuff except that I can only use Picos as buttons, so I end up with all these switches that are only really useful for the dimmers inside. In an ideal world, I would only have dimmer switches that follow modes to keep things less confusing for everyone else in the house.

Do you mean that the dimmer would turn on to a different level depending on the time of day? If so, I’m sure that this is something that can be programmed, and there is most likely also an app to do that in the community…

On thing to consider is, if you are controlling multiple dimmers, programming your scenes in the Lutron app and then calling that scene from Hubitat. You'll get better performance (no pop corning, everything comes on to the correct levels). The Lutron bridge will hold 99 scenes. The bridge is a button device in Hubitat, so just have Hubitat push the correct scene button.

2 Likes

Can you call a Pico button the same way? I'm having trouble doing so. I see the physical button presses reported, and I can issue a push and release command to the Pico that get reported as having "digitally" taken place. But I see no corresponding lights coming on. I'm pretty confident that I have them set up correctly in the Lutron App. What follows is a snipit of the Lutron Integration Report. Is it weird that the button numbers start with 2? That they have no actions associated with the buttons?

"Name" : "Master Bathroom Pico",
"ID" : 26,
"Area" : {
"Name" : "Master Bathroom"
},
"Buttons" : [ {
"Number" : 2
}, {
"Number" : 3
}, {
"Number" : 4
}, {
"Number" : 5
}, {
"Number" : 6
} ]
}, {

You can call a Pico button in the same way as a bridge button. A bridge is a 99 button device. A standard Pico is a 5 button device. Anywhere in Hubitat where you can virtually push a button you can virtually push a Pico button. The only information from the integration report you need is the ID. You use that ID when you add the Pico to Hubitat. The button numbers don't matter as Hubitat renumbers the buttons 1-5 from top to bottom.

1 Like

No, the communications for a Pico remote are one-way, from the Lutron bridge to the Hubitat hub.

Thanks. It is nice to know that I wasn't doing anything wrong.

Download the Hubitat app