Mode Manager stuck on Evening

This morning mode manager was stuck on evening.

So I checked the hub browser time and it is correct for morning.

So I went into settings > Modes and MANUALLY selected current mode to be Day.

Not sure what this scheduled task is and why it's for just after midnight?

Still shows I'm on evening mode. I've tried rebooting the hub, and I've tried completely removing Mode manager, and re installing and configuring it.

I disabled HubConnect to see if I could manually change the mode back to day, and it stays stuck on it's not a HubConnect issue.

Please show the Mode Manager setup.

When you have a Before Sunrise setting, the very first day it schedules something just after midnight the next day (notice that it says 6-28) in order to determine what time will be that many minutes before sunrise. On other days after the first day, this event happens when the hub sends out a sunriseTime event at sunrise, giving the sunrise time for the next day (the first day we've missed that event, hence the need for the just past midnight event).

Check your System Events log to see when these events came out. Check Mode Manager events (from app status page). Post these also.

Was this working before today?

That explains that part, because like I posted I tried uninstalling mode manager and re-installing it to see if that would work or allow me to manually set it back to "day" mode which was therefore my event logs are empty because of the "re-install" but I did look at them prior to this and it logged an event changing to day at the scheduled 30 before sunrise. But Mode manager didn't reflect that.

Yes this was working fine before today.

And the most recent one is

What do you mean by this? So mode changed to Day when it was supposed to? What do you mean by Mode Manager not "reflecting" this? Are you talking about how it looks on the app page?

I meant the events showed this changing to day mode.

But Mode Manager itself still showed


Just like right now I can go into settings > Locations and Modes and change Mode to "DAY" click update

The page refreshes to show

But the Homepage still shows


Apps page is not Dynamic... so you clicked browser refresh, right?

Yes, and I've selected the settings page, then back to the apps page multiple times trying to figure this out.

@bravenel I found the problem, sorry for wasting your time.

It was a (bad) rule I created yesterday attempting to compensate for mode manager setting based on presence return.

1 Like