Mode Manager Not Working

EDIT: Already uninstalled/reinstalled and rebuilt mode manager once and that didn't solve it...

Mode stays set until I manually change to night/day/evening/etc...
Read through a bunch of posts on mode manager problems and can't seem to figure out why!

Seems like a familiar and simple widget so I'm guessing I'm new and just missing a simple process that is outboard of the Mode Manager app.
Right now my goals are:

Simple time based mode changes: At xxxtime change to xxxmode etc...
When all phones depart mode changes to away
When any phone returns, mode changes back to whatever time of day it is

Hoping ya'll can help me figure it out.

I can't see anything odd there, though maybe someone else can if I'm missing something.

I would:

  1. Check "Enable logging" and then see what's in Logs around the time you think mode should have changed.
  2. Verify your location and time zone (and time, etc.) are correct in Settings > Hub Details.
  3. Hit "Done" in Mode Manager to re-initialize things.

Done: I've hit Update/save/Done everywhere I can see to do so and feel like its locked-in since Appy shows "day" in green and that updates when I manually change modes via dashboard button.

Screen Shot 2022-12-29 at 9.24.01 AM

SCHEDULED JOBS: seems like it should have more mode-manager events to me?
2100/9pm should have changed to NIGHT. right on schedule in the scheduled job tab although I do not see the the evening shift at sunset+10 though.

Seems to show Sunset/Sunrise pretty routinely since I setup

This is what mine looks like. It operates just fine.

It might be that you need to specify the time period for the presence sensors.

Thought maybe a bug with the SUNSET+10 so I changed sunset/sunrise+10 to a specific time.

10am should have changed to "Night" but it missed again and failed

Sun times are events, so the app doesn't need to make a schedule for them: for things at sunrise, sunset, or either one plus a positive offeset, they can just subscribe to the event (and wait some time if needed). You would get a scheduled job for negative offsets, though I don't see any in your setup, and possibly not until the next day when it knows that day's sun times (this depends on the app and I don't know how Mode Manager handles this internally; could be part of what it looks for at midnight).

If your app is still set up as that table shows in your first post, I don't see anything missing here.

They should work without it; that is only necessary if you want to ignore presence events outside a certain timeframe.

Probably not strictly needed, but if we are away and then come home, I want the mode to be set to the correct mode for the time period in which we arrive. If during the time we will normally be awake, then I want it to be in home mode. If, however, we are away and come home late, I want it to go direct to night mode and not home since the temperatures on the thermostat are based on mode. In any case, what I have is performing correctly so I will stick with it.

That is what the "Return from Away" settings do, all on their own. :slight_smile: But if you have something working, no need to change!

I think I figured out the problem but want a couple more mode-changes to occur. Keep in mind I'm learning!

Here's how it went down:

  1. Originally built BASIC RULES for various lights on/off at sunset etc...
  2. Discovered ROOM LIGHTING app which seems better suited for this task
  3. PAUSED BASIC RULES and setup LIGHTING PERIODS via ROOM LIGHTING app to automate on/off lights at desired times via mode change

Only when I fully deleted the BASIC RULES did MODE MANAGER begin to obey DAY/EVENING/NIGHT commands.

Day->Evening worked after making this change. 9pm eastern will see if Evening--> Night works as well!

Seems like the paused BASIC RULES was the issue. Also seems like PAUSING should have been sufficient. Will update when we get through NIGHT/DAY again tomorrow.

It should be, so if the problem is fixed, I suspect it was something else.

Seemed like the mechanism was blocked but now its working as it should with straight-time events. I'm going to switch back to sunset/rise+ and see if that works.

The issue seems to have been one o 2 things:

  1. Sunset/rise+ time setting instead of straight-time
  2. Basic-rules (paused) clogging up the works

Lets see is sunset+/- works.

See ya tomorrow!

Thanks for the update. I hope it works.

Seems to work ok now

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.