Mode Manager Issue

Hi Hubitat Community,

This is my first time creating my own thread, so my apologies if I miss something or am in the wrong section.

General Information:

I am in the middle of migrating from Smartthings and am trying to get Mode Manager working correctly. We have no issues when we leave the home (it gets set to Away), but when we arrive the mode is always set to Night, no matter what settings I adjust or the time of day.

I have a virtual device named Home Presence that acts as as combined presence option for my partner and I to determine when are are home:


Solutions tried thus far:

  1. Uninstall Mode Manager , reboot, install Mode Manager, reboot
  2. Adjusted various settings in Mode Manager for troubleshooting
  3. Tried Mode Manager without using presence detection (seems to work fine) based on the schedule only option.
  4. Watched the official Mode Manger video: How to Set Modes and Use Hubitat Mode Manager - YouTube
  5. Various Google searches

Mode Manger Info:

Here is how Mode Manager is currently configured:

Here are the most recent Mode Manager Logs:

Extra Info:

Device: Habitat Hub C-7

Habitat Hub Version:

Thanks for looking at my thread!

Looks pretty straightforward, at first blush, since you are asking Mode Manager to switch into literally every mode upon arrival. I suspect your Hubitat is therefore saying to itself, "Somebody arrived, lemme go ahead and switch from current mode to Day, then to Evening, [leaving out some] then to Night."

Not what you expected, I'm sure. It begs the question, "Which mode did you really want Hubitat to switch into when someone arrives?" Get rid of the others from the "Set Mode Based on Presence" section.

At least that's my baseline advice.

1 Like

As @LibraSun mentioned, you actually over-configured the app slightly. Here is what mine looks like, and it behaves as expected.


Thanks for the quick reply everyone! I will give it a try with these settings:

EDIT: Those settings yield the same result. Here is the log (2 attempts Away->Arrive):



Remove Mode Manager and then reinstall it with your recent set of settings. Sometimes old settings don’t really go away properly.

1 Like

The logs from the updated rule are not at all like the logs in the first post.
This new one looks like I would expect if presence is departing and arriving.

The time is night, so you change to away when you leave and from away to night when you arrive.

What is your expectation here?

1 Like

In theory it should be Evening when I arrive before 11:30pm; not Night (at least, that's my goal).

Uninstalled, rebooted, reinstalled, rebooted.

When returning home the mode doesn't appear to change anymore (it is the same before I leave):


EDIT: Thinking about it more and doing more testing I think I finally have it (once I matched the settings from @ogiewon). l will monitor over the next few days and report back.

Thanks everyone for your help! :blush:


After a few days of testing: The settings from @LibraSun and @ogiewon work.

When everyone is Away, the mode is Away.

When one person (or both) arrive home, it is set properly based on the time of day.

Thanks everyone!


Glad to hear it is working now. Thanks for the update!

1 Like