Mode manager bedtime lockdown

Good evening cleaver peoples, I am struggling to get my mode manager to change to bedtime mode I have 2 withings sleep tracking mats and wanted to set a mode for when they both have presence sensed so Hubitat will know when everyone is in bed and to turn stuff off ect, is this possible?

Looks like that should work OK. Is it not functioning as expected?

no it doest seem to function at all, I have automatons with the sleep mats to turn the bathroom light on and off so its got connection, I will see if I can see any logs tonight.
Thanks for quick reply

Yeah definitely. I would turn it on for mode manager and those two mats.

1 Like

I managed to get it to active there bedtime rule by not giving it a choice and deleted all other modes
still getting errors tho mode manger is definitely bugged out, It may be time for me to delete and restore

I haven't got any other logs available but it won't even change out of bedtime mode in the morning at set time

So, looking at your initial rules, the "Home" setting you have where "all" arrive may be creating a conflict. Basically, if you are both in bed then you should ALSO be both present. So, which mode change takes precedence?

Looking at your most recent settings, you have a "null" in there and bedtime should be in the timed settings with a "skipped" checkbox (unless you want it triggered by a time also). Looks like something may have gotten corrupted when you were editing/deleting your modes. I am betting that is the cause of the errors in the log. Did you have another rule hanging on to one of the modes you deleted?

I hadn't played with modes for a while I don't think I had any rules in place, I can't delete null I was hoping a soft reset would fix it, I will try to delete mode manger again to try and get rid off this bug.
I would like bedtime to take precedence but if I can ativate 2 modes at a time that would also be cool

Same problem here when I just checked. I have 2 "null" modes and the dropdown to remove modes doesn't list them.

What does it show for modes in the mode settings themselves (Have to click "manage modes" at the bottom or go to settings -> manage modes). This is really where you should be creating or deleting modes.


Understood, the "remove" action is just trying to remove the mode from the table, that's all I was trying to do. I'm currently at work, I'll check for those modes when I get back home. I haven't created or removed any modes in at least a year. Mode Manager 2.0 has been a bit wonky (for me) since it was introduced. I've had some modes not change (for no apparent reason) in the last few weeks. When I checked, I found the non-removeable "null" modes as stated above. Thanks for the suggestion! -Joel

It's probably not letting you remove the actions because there are ghosts in your mode table. (Just a guess)

I don't have any "null" modes in settings, but there are two there that may be associated with the "null" ones in Mode Manager. Seems like there's something missing wrong in the translation, lol. @bravenel, any ideas?

Two things:

  1. Update to latest release.
  2. Remove Mode Manager and recreate it from scratch.

Done, I was on the latest release and have removed/recreated Mode Manager and the "nulls" are gone. Hopefully this helps out with the random missed mode changes. Thanks Bruce!

I fixed my mode manger by checking there was no old rules linked to the modes, then deleting all existing modes and mode manger then doing a soft reset, and its all fixed for me and seems to running how I like it at the moment. I may have been a bit extreme with my fix but like to get rid of all possible bugs. Good luck

1 Like

I just found that check it out