Mobile App not connecting

I recently upgraded from C-5 to C-8.

After a few days notifications stopped working.
(everything works correctly with the web app -- I have a fixed IP).

I figured why not remove the Android phone device and reinstall it. I did the following:

  1. remove the mobile device in the web app locally
  2. removed and reinstalled the mobile app on Android.

Now the app will not connect with my hub - It says the C-8 hub is unresponsive, but it still gives me the option to select the hub -- which is clearly online from

The app either spins at the stage "Loading Mobile Devices" and peridodically throws an error like "okhttp3ResponseBody$1@22Bf706"

Any suggestions most appreciated.

Note: just after I posted this the hub now shows as unavailable in the portal -- after more than a day of showing available.

PS. I have tried rebooting the hub.

Everything on my network is fine (running tests at http://192.168.XX.XX/hub/networkTest ) is now showing zero hubs associated with my account.

I am guessing there is a problem at Hubitat to be resolved.

I found the problem .... somehow the C-8 turned off fixed IP in the network setting -- so there was no config for fixed IP or DHCP.

Everything worked locally, but this stopped things working to !?

Correct because the arp table had not been flushed so the routing still worked locally and yes it will stop the portal from working. So your fix above was the solution to your problem.

Download the Hubitat app