Mobile App for Android - Using VPN

Not sure which version. However, back in December of 21 is when I noticed and submitted a help desk ticket.

So, prior to that time frame, when I left home and was connected to my home's VPN (Either Wireguard or OpenVPN), using the app as "local" was transparent.

I don't run the VPN for hubitat exclusively. I started running it mainly for access to my local NAS, my cameras, and monitoring my 3D printer. All of those work flawlessly with VPN and no issues with startup of the native apps that look for a local connection. (I did have a minor issue with OctoApp app because it was initially set up to look for a different host name than I use on my lan. Once I settled that, it now works flawlessly as well)

At some point, it started opening the app with a prompt to purchase the remote connection service. At that time, it was simple enough to click once and go to the find hubs screen, select my hub, and continue on. Annoyance level was there, but it was minor.

Recently, something else has changed, and now it is several clicks. Annoyance factor is increased. I do not use it often, but when I do, I really don't need it taking as long as it does to get to the hub.

If I use the browser on my phone, it doesn't have any issue. But, there are several reasons I prefer the navigation of the app over the browser while on my phone.

I sent in a trouble ticket, and I was told this was not intended behavior. But, I haven't had any follow up.

Support Response

So, I am wondering if I am the only one experiencing the issue. Also wondering if the issue is the host name I use (Even though the app shows numerical IP at the top when connected). Or, is it specifically looking for something else to see if I am on my home network?

Again, it's only an inconvenience. But, since I have to re-run discovery EVERY time I try to use the app on VPN, it is becoming the water drip of water torture. Would love to have a workaround that could fix this (or have the developers work on a fix if it isn't just me)

Again, if this is intentional for security purposes, I can accept that. However, if it is not expected behavior (as the support ticket indicated), I would love an update on whether or not this is fixable. (For instance, the OctApp added a feature that allows the app to search for the specific local IP on open instead of the host name. All the user needed to do was select the IP address on initial setup. As long as that IP was found and had not changed, the user never has to search for the printer again. )

Edited to add, If I am the ONLY one having the issue (or the only one annoyed by it), I truly don't expect support to address it. So, if it is not just me, it would be great to let the support team know.

I use the IOS app like you (vpn from the outside when I'm not around) I have never gotten that screen. Are you on the latest android version?

I have my home WiFi Router setup to use Open VPN, so when I'm traveling I can be connected to my home network just like if I was home. When I fire up the Hubitat App on my phone I need to go to "Tools" then "Registered Hubs" and I click the "Connect to Hub" which will bring up a login page where I enter my Hubitat Hub login in credentials. After that, I have full access to my devices, etc. just like from my web browser at home. I can do all of this when I'm running the OpenVPN app on my phone first before launching the Hubitat App.

Yes, I keep it on auto update. I believe there have been 2, maybe 3 updates since then. (Correction, looks like only one update to version 1.6.8 on Jan 6, 2022 - But no updates available in the play store)
Screenshots of all the steps required. The "setup hubs screen" is the one that was added since I originally sent the ticket in. Before that, it was three clicks. But before all of that, it was just one.

Click One

Click Two

Click Three

Click Four

Finally in, note the IP in the top of the screen


My point was that before, all I ever had to do was open the app and click connect to hub. That was on VPN or Local. Now, if on VPN, I have to go through all the steps listed above to connect to my hub,

On the browser, I just type the IP. However, as I stated earlier, I prefer the app when on my phone. The browser interface wasn't designed for phones and it just doesn't work that well (for instance, when you are looking at your Z-Wave table).

I rarely actually need the app except if I am traveling (which I do for work). Most things are automated and I only need to go in if I need to check the logs, or do some maintenance like reboot or some such. However, it kinda smacks me in the face when before it was as simple as clicking the "connect to hub" link in the Click One image on my other post.

It seems like they could store the registered local IP and just have it open that when you click connect to hub. Then, it would only force the registration process if that IP was not found. That is how most of my other apps work.

Edited to add.... Will try the "registered hubs" path. That looks to be at least fewer clicks than current practice....

I'm only seeing the registration screen only when I'm not connected to any WiFi. When I'm connected to a WiFi networks, although not the local Hubitat network, I'm not seeing the registration screen when connected to my VPN server.

I think the Hubitat app look what kind of connection you have (WiFi or not WiFi). If not WiFi and you are not registered, automatically go to the registration page. For me, not really a problem since I mainly use a web browser pinned to my home screen.

1 Like

I don't usually connect to external wifi, maybe that is why I haven't noticed that.

1 Like

I noticed this on the App as well when using a VPN, but a shorter method than above is to click on Registered Hubs first and then Connect to Hub button, that goes straight to the IP.

1 Like

Following up. It is 100% only happening when I try to connect with WiFi off. I tried it while out today. Three for three would not connect directly on Cell, but would when I connected to Wifi. Maybe that helps the engineering team narrow it down if they are still working on it.

1 Like

@moncho1138 Any thoughts on this?

I used to use OpenVPN and just book marked my hubs and use the browser. Open VPN started getting flakey. After setting it up several times eventually it would get flakey again. I use an Asus RT-AX3000 and noticed a native app in the settings called Instant Guard. That works very well for me to be able to connect to my hubs from outside my network without issues.

1 Like

Download the Hubitat app