Mobile app broke

So now the mobile app seems broke... swirling circle then Error url: code 504 body okhttp3 .ResponseBody$1@6cc06ad

so... hub completely unusable remotely

W T Heck?

I dunno if I can help with the error you’re seeing, but that may not be entirely true. Do you have any links to your cloud dashboards saved? If so, have you tried opening in a browser?

1 Like

Does it also happen when you force close the app and start it again?
Are you on 4G when it happens?
Is it Android or iOS?

1 Like the internet connection at your house up and running?

Keep in mind, you are connecting to your hub. If your hub is down or the internet connection is, the app can not talk to your hub.

This will be addressed better in the future, but this error is indicative of your hub or ISP not working, not a fault of the mobile app.

The mobile app can't even tell me if the hub is up/reachable or down?
...glad I'm not using it for a security system.

Same for the sensors. Once paired, I;m not sure we know if a door sensor for example is communicating or if it's dead/out of range.

I'll check when I'm home. In the house, lights worked from the app this morning.
And I was streaming TV so the router was intact.
I'll have to go over the connections. Maybe the hub's to close to my router, they live in the same closet.

I have two production Hubitat Elevation Hubs within 2 feet of my Asus RT-AC86 router. No problems. Definitely not the most recommended geographic configuration, but it has been working for me for years like this (i.e. ST hub was in same spot prior to switching to Hubitat.)

Since the hub has no WiFi radio, being in proximity to your router would not affect it's ability to connect to the internet. Devices, maybe, but not the cloud. That is through the wired lan connection.

As I stated above, the app will handle when the hub is unreachable. We do not store data in the cloud regarding your hub status, devices, etc. So the app must be ether able to reach the hub, or tell you that it is unreachable. Right now, the error isn't a pretty error, its a raw error. That will be fixed down the road.

Also, currently in beta, is the ability to access your dashboards locally, even if the hub isn't reachable to the app via the cloud relay.

I would like to note that a few days ago I started experiencing the same behavior.

At home, connected to wifi the android app loads on my phone but gives "Error" url: code: 504. body: okhttp3.ResponseBody(some numbers here).

I have force closed, restarted the app. Uninstalled the app and in re-installed. upon re-installation it found my hub and started fetching user info and then did the same thing. I also have rebooted the hub and it didn't help.

I want to note the hub is online and working perfectly on my amazon fire HD wall mounted tablets. My internet and wifi are all online and working perfectly. The only issue is the app connection to dashboard on my android phone, and also my ipad app.

Very odd, appreciate any help or guidance.

At home, is your phone on the same subnet as your hubitat? Do you have any special networking "stuff" set up on your network or is it a straight home wifi setup with nothing special?

Ryan780, it's standard with the only caveat being I have an extender in my garage. For some odd reason, a few hours after posting this everything started working again.

Mine was weird. When I got home the hub worked from WiFi but still didn't from wireless data.

I still get a "token expired" message when I start the app after a long timeout of some kind.

Power cycled the hub and back in business after I ignore the "token expired" after 5 seconds of a blank white screen.

I have the same issue. No problem reaching the local dashboard from the user portal over my home network, but no remote access through the app.!


I'm providing another data point.

My Hub has been up and running fine for at least a week without any reboots/etc. Was informed today by other family member that they couldn't get the mobile app to bring up the dashboard, so I checked my phone and it wouldn't load either. Even though I've been accessing the hub fine through the windows PC for over a week without any interruption, so the hub was still functional.

Rebooted the hub anyway, now both phones can access the app again.

Do you by chance use snapshot? I had too many devices set to real time and it would slow down the dashboard and not let me access it remotely until I’d reboot the hub. I dialed back the reporting frequency of snapshot and all has been well since.

Nope I don't use snapshot

Was also getting

url: code 504 body okhttp3 .ResponseBody$1@6cc06ad.

Rebooted my hub and access through the mobile app worked fine. That was a week or so ago. Had to reboot on Saturday. Now again today. I will keep track of how frequently I need to reboot.