Missing Humidity values

Has anyone encountered the issue of missing humidity from a generic zigbee humidity /Temp sensor.
When I add the sensor I get the following information which suggests the capability is there.

No matter what I try I only get battery and temperature reported from the device.. no log errors etc.
Sorry for this post if this issue has been discussed somewhere else.
I've spent a few days searching the forum and doing all the usual stuff like resetting Zigbee, playing with channels and different pre-installed drivers .
Many thanks for any advice from the experts out there..

Is this the z-wave version or the zigbee version? They make both.

There is no Generic Zigbee Temp/Humidity Sensor driver. There isn't even a generic Zigbee temp sensor driver. So, you're lucky you're getting that much. What is the driver it is using now?

Try using the “SmartThings Humidity” Driver. It supports both temperature and humidity for a Zigbee device. After changing the driver and clicking SAVE, e sure to also click CONFIGURE.

Not sure if this driver will work with your device, but it’s worth a try.

1 Like

Thanks for the reply folks.
It's a zigbee sensor - I've tried the SmartThings humidity driver along with serveral others such as the Generic Humidity/motion sensor and some of the multi sensors which should get me Humidty (smarthings, smartsense etc).
In all cases I can get a device state for Temp but nothing whatsoever for humidity.


I'm not very familiar yet with the coding but on the device data I see the zigbee cluster for Relative Humidity 0405 so can't see why this is not being reported.
The only thing I can think of looking at the device info is how the Humidity seems to be in a separate section (idAsint:2 /endpointid:2) to temp (idAsint:1/endpointid:1)
I could be interpreting this wrongly of course - I cant' seem to find anything on these identifiers in the Zigbee standards (but theres a lot of info!!).
Any thoughts ???

Thanks again for your suggestions!


Use the above driver

However depending on how frequently the device itself reports a humidity reading it may take a bit for the device status to show the reading. The device has to report the status before the device details will display it.


Thanks for the suggestion. I've tried this driver before but have just tried it again.
Monitored with the same result as my previous screen snip - Battery and Temp reported /updated but no mention of humidity....

I would say it's device related issue then as I'm currently using that driver with an Iris V3 motion sensor and it reports humidity fine.

Did you hit CONFIGURE after changing any of those drivers (and hit the config/program/wake-up button a bunch while trying to configure)?

Sounds like the BIND isn't set on the device to send the humidity reading to the hub. That is usually setup on install and/or when CONFIG is pressed on the device detail page.

I was thinking the same but found someone has had the same issue with this sensor..

Will keep working on this for a more days and then consign the unit to the sensor graveyard in the back of my toolshed :grin:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.