Missing fundamentals about Ring Keypad G2 input

I couldn't choose two solutions, but either exclude+pair or else smartstart pair fixed it.



Smartstart seems to be the key to any zwave device that you need to use Security (keypads, locks, etc.)

LOL - FWIW I paired mine without SmartStart - but maybe I just got lucky


of note, after re-pair (with smartstart), mine shows it too:

  • secureInClusters: 0x59,0x85,0x80,0x70,0x5A,0x6F,0x7A,0x87,0x72,0x8E,0x71,0x73,0x86

Yep, I have had awful luck with SmartStart and added dozens of Ring devices normally. Sometimes they need an excluse/re-include but in general not too bad (except the damn contact sensors which are brutal to add).

I have done all these methods to troubleshoot and still have the same one way communication. I’m completely lost here. And additional ideas?
Smart start for some reason randomly adds duplicate items (I have excluded and reincluded over a dozen times using every possible method. Always end up with one way communication)
I’ve powered down the hub after excluding the keypad. factory reset the keypad retired the smart start and nothing. I even went as far as putting the keypad in foil, then inside a metal box, then driving it 10 miles away and remotely restarting hubitat then repairing the zwave and assuring there was no ghost device. I then factory reset the keypad before bringing in any closer than 10 miles and still, after rejoining using the smart start, 1 way communication only!. What the heck? I’m loosing a lot of hair over this one.

I have all the same symptoms @jkister had. Except, his solution clearly doesn’t work for me.

I was having the same issue as jkister. I had originally started in smart start. So, I tried this again, and now I can't even get it to add at all. I literally just reset my entire zwave network. I only had three devices so not a huge deal. But now for some reason I can't get it reconnected.

i bought a hubitat
i bout a ring keypad g2 and hub
i installed the community app
i could not get the kepad to talk back to hub.
Do i need to put in rules?
i uninstalled the community app.
I installed the unofficial ring virtual app.
I could not get the keypad to talk to the ring hub.
do i need to apply a rules machine?
Both applications allowed the hub to talk to the keypad .
Both applications would not allow the keypad to tale to hubitat or ring Hub.
I will keep trying but if someone can get me to the basic's i will work at it until i understand and win!!!

I had the same problem with the G2 Keypad. Hub did not get any key presses. Tried many times the steps outlined in this thread. I was able to GET IT TO WORK finally! Only thing I had to do was to keep the KEYPAD RIGHT NEXT TO THE HUB. Used Smart start to add (I don't know if that it is even necessary, classic inclusion might work as well). Did not even disable the proximity sensor. After that it worked flawlessly. However when I move the keypad away from the hub where it failed to work (hub is downstairs, keypad upstairs, 30ft apart may be) it failed again. Never got to work as before even if I bring it closer to the hub. i.e no key presses goes to the hub. I had to reset it and add again. I even added a second keypad. Both works perfectly. But the two keypads does not sync with each other. i.e If I arm from one the other does not change states. I can live with one for now!