Missing documentation - IRIS Smart Plug (3210-L) Z-Wave Repeater

On the Compatible Devices page of the documentation (List of Compatible Devices - Hubitat Documentation), it lists the ' IRIS Smart Plug (3210-L) Z-Wave Repeater' in addition to the Zigbee side. But if you look at the Iris section of the Join an Reset instructions (Join and Reset Instructions - Hubitat Documentation) linked on the same page, the Z-wave portion doesn't exist.

I can't swear to it, but I was sure that was where I got the instructions for joining the Z-wave side awhile back.

The online videos are gone. Looking around I found the instructions I used on Smarttings site.


I used the sequence of holding the button down when plugging in. This gave Zigbee pairing. The Zwave was a little harder. With the module plugged in, hold the button down until module light flashes, then rapidly press the button 8 times. I had to do this a few times as if your too slow it thinks you want to turn the outlet on and changes state. Have to start over.

1 Like

Thanks Rich,

That's close to what I was using. I've tried a few different ways and can't get the Z-wave portion of the plug to get into Z-wave pairing mode. I tried your instructions to a tee a few times and gave up on it. So I broke out another plug from my (too many) spares, paired it via Zigee, then paired it via Z-wave no problem.

I've not had good luck out of the used Iris plugs so far. Both of the 2 I've used has had different issues. Let's see how this 3rd one fairs.

But the original item in this thread still stands in that the Hubitat documentation is incomplete and needs correcting.

1 Like

I was reading another thread and the op didn't hold down the button to start Zwave, just pressed the button 8 times rapidly after the zigbee pairing is complete. (Still has to be quickly)

Maybe try a z-wave exclude, then pair?

1 Like

Been so long I forgot about that. I did buy them used from Ebay and had to exclude them first. Seem to recall (now) I may have had to exclude some more than once. Sorry, old brain has slow index system, if it works at all.

1 Like

Thanks, but I already attempted multiple exclusions both using the Hubitat and an Aeotec Z-stick. I suspect there may be another issue with that device as it won't do a factory reset either. However it's still currently working well as a plain Zigbee plug in Hubitat.

I didn't need another Z-wave repeater as my mesh is very strong given the small area it has to cover. I was going to do some testing with the plug using the Z-wave Tookbox and report the findings back to the community. Yeah... the old saw applies, "Don't fix what's not broken!" It's a habit as I often try to break things (mostly PC related) so that they are personally well tested before I recommend them to customers.

I thought I had a strong mesh til I added 4 of these plugs... actions with zwave devices are much snappier now.

Z-Wave alliance does have some info for the Z-Wave part.. also how to reset

https://products.z-wavealliance.org/products/1492

Installation Manual

edit: although this has shown not to work all that well for some devices.