Minoston M21z

I was able to setup the receptacle and did a simple automation to turn the receptacle on/off. I wanted it to work with Alexa but it doesn't show up in the skills. What do I need to do?

Did you go to Apps, Echo Skill, Select Devices, and check the box to allow it to access Alexa? (the grey box below)

1 Like

Yes I did but the device is not there. I had checked the hubitat documentation and the MP21Z was there and when I checked Minoston said it worked with Alexa. When I first setup the receptacle it did not have the Minoston as a receptacle but it did have it as a switch. I also changed it to Generic Zwave receptacle but that didn't work either. I want to set time on/off . It works that way but no Alexa. In the Echo Skill the device is not shown. I have 6 zooz receptacles and they all work well and with Alexa. I needed a mini receptacle for this location by the TV. These are for the lights behind the TV. I had checked your suggestions but still no Alexa. Do you know of a mini zwave plug that will work?

If the plug isn't showing in the Echo Skill, something is very wrong. Every item in the Device tab should show up there. Even devices that don't work with Alexa show up in that "Select Devices" list in the Echo Skill.

Are you sure of what you named it? Could it possibly be showing up under a different name like TV receptacle instead of Minoston or vice-versa? Maybe it is under the name Generic Zwave Switch?

That doesn't really matter as you are using Hubitat, and it is what exposes devices to Alexa. Devices that don't have that marketing label will work with Alexa if you pair them with Hubitat.

That is OK. There is not a specific driver for every device, nor is one needed. Many devices work with the default driver or a generic driver. Many of these outlets come into Hubitat as a switch.

Can you do a screenshot of your device's setting page (where you change the driver)? It might take a couple screenshots to capture the whole page.

1 Like





Hope this helps. Thanks

why do you have hub mesh turned on? Do you have 2 HE hubs?
If not , turn off hub mesh

IMHO, you should set the device "Type" to the built in "EVA LOGIK Smart Plug". I have multiple of the dimmer version of that same Minoston plug and the EVA LOGIK drivers work better. (Currently the built in EVA LOGIK drivers work best for all of the zwave products based on NIE Technology which are sold under multiple names like Minoston, NewOne, etc. I say currently as I'm working on better custom drivers for them...slowly working but still.)

I don't know why the generic one may not show up in the Alexa skill, but it should definitely show up with the EVA LOGIK one. I have multiple of the Minoston dimmers and one of the outdoor outlets all working fine in Hubitat/HomeKit/Alexa with them set to use the EVA LOGIK drivers.

As an aside, I very strongly suggest you rename the device to literally anything other than just "TV". Alexa seems to have a strong affinity for the name "TV" to be an Alexa-enabled television or Fire TV/Stick. I bet you will have all sorts of problems trying to tell Alex to "turn on TV" or "turn off TV". At least call it "TV Light" or something.

I changed name to Allen. I changed driver to EVA LOGIK receptacle. Alexa now just says that she didn't find a group or device named Allen and it doesn't show up in the skills. I also removed Hub mesh. I look at the Alexa app on my Iphone and is says 38 skills enabled but doesn't give me a list.

I just added my Minoston MP22Z plug (set to EVA Logik Smart Plug) to the Alexa Skill and it showed up my Alexa app (Android). I am using a secondary hub (a C5) as my cloud and network hub and Hub mesh so that is a bit different.

Did you try and search for devices in Alexa?

Also maybe create a virtual switch in HE and see if you can add that to Alexa. Maybe there is something funky going on with the skill. You could revalidate I guess.

Just for completeness in being sure you did all the steps, you DID click on that grey box with all the devices listed? And it still won't show in that popup list if you click on it?

That list you screenshot doesn't automatically update, you have to go in and select the devices manually. Then you must click Update.

This is before I click on the box

And After

2 Likes

Could get the Minostoon to work so I bought a New One plug. I included on hub no problem especially when New One was on the list. Saved and it works on the hub but not Alexa. Again I went to the skills and it doesn't show up so when I tell Alexa to turn on Trouble(device label) I get "Sorry I don't know that". I have a bunch of Zooz receptacles and switches. They all show up on the device list and the skills list. I can't use the Zooz because of its size. The New One just fits. I don't understand if Hubitat has it on the list why doesn't it show up on the skills. This is driving me crazy.

You must be missing a step someplace in the Echo Skill. Every device should be available, as shown by my screenshot directly above. I have ones that are virtual devices, and even some dead devices (like the Magic Cube) that I have never removed.

You are saying it does not show up in that selection box? Not the first grey box, but once you click on that grey box the popup doesn't have all your devices?

Did you try rebooting the hub on the off chance something is just being weird?

2 Likes

Got it. Thank you Neoturbo. I had to click outside the gray box then it showed up and click update.

2 Likes

Download the Hubitat app