Migration Problems

Hi All,
I'm a new owner migrating from Wink and things are not going particularly well. I registered, setup, updated and tested two GE Link bulbs and Simple Lighting last night. It was fine. I then started working my way around the house this morning.

With some persistence I added some Lightify RGB bulbs and a few more GE Links this morning. Things were progressing but not without some retries and difficulties setting the names on the newly discovered items, seemed par for this technology. Some would be discovered but not show up as generic or their assigned names. I persisted until they were all present and working.

I then moved on to an GE/Jasco Z-Wave toggle dimmer. I was and am still having problems adding one. I moved onto another identical one which was fine, exclude then include. No problem.

I went back to the problematic toggle dimmer and tried a variety of reset procedures, and pairing attempts without success until one time I looked down at my phone and it says the hub is initializing 75%.

No here is where it gets ugly. After it finished booting I am left with only the two bulbs and simple lighting rule from last night. The many other successfully installed devices from today are gone. It was nearly 2 hours of work that has vanished.

The frustration went from say 2/10 to 8.5/10. I left out that I had added a large number of Chromecast/GH devices and one successful and one unsuccessful Onkyo receiver as well in case that raises any flags. I can get into more details if anyone wants to help but I didn't want my first post to be any more epic. I probably need to go do some chores before I can get back to playing with my new toy so...

Thanks in advance

Sorry about the formatting, I didn't intend the code block and can't seem to edit it if a mod wants to fix. 9/10 now :stuck_out_tongue:

Fixed the formatting, FYI, 4 spaces is forum markup for preformatted code...

Anyway, what you are describing sounds like something caused your DB to be corrupt and it automatically recovered but restored a backup that was older (before you finished setting things up).

Good news, it recovered, bad news, you lost what you were working on.

Highly recommend grabbing a backup in settings after major changes just to be safe.

Now as to what caused the DB corruption, that is an unknown. Hub losing power is one rare cause we known of. Always best to shutdown via UI when possible.

Heat related shutdowns can also be a problem, so if it was in a hot room or in direct sunlight, we've seen isolated cases where that can cause issues as well.

Bottom line, gonna have to start where you left off and grab a backup as you go. Keep an eye on it and if it happens again, reach out to support.

Got it thanks. Thinking back to typing/English class it was 5 spaces to indent a paragraph since the Tab key doesn't work in more and more places now.
I'll try it all again later I guess. I did notice the backup feature but still have a long way to go before I added all my devices so I hadn't used it yet. I may have to slow my roll...

Are there any known problems adding multiple devices at once? I have a lot of zigbee bulbs some in the same light fixture so it is easiest adding them together to avoid the ladder. I've noticed my greatest difficulty adding multiple bulbs. I see them all flash/pair but then I cannot successfully name them and only one will show up as "Generic..." sometimes that I can rename. It was slowing me down considerably.

If you mean 'one trip up the ladder' then yes. You'll need the phone up there with you to click Save on each paired bulb. You can do the name/rename later, although you will have duplicate names (the DNI will be unique, as it must be) and may have to toggle them to ID and create a specific name.

Many devices pair and use one of the 'Generic xxxxx' drivers. That's OK. When the device pairs as 'device' then that means the 'fingerprint' that was acquired is unknown to Hubitat. If you see that, screen cap it and send it in.. they'll add it and the next guy won't have that one problem :slight_smile: Screen capture it immediately. It's only visible on that screen during the pairing process. :slight_smile:

To summarize, assuming my imagination isn't to far afield... You have 4 bulbs in a fixture, you climb a ladder, pair them individually. Each one shows as Zigbee Bulb ## using the Generic Zigbee Dimmer driver. You climb down, and on the device info page is a list of 4 Zigbee Bulbs with a number, you can't tell which is which, probably.. so.. click one, turn it on/off and then rename it right there in the device info page. You'll see the Device Name field and go ahead and leave that untouched.. below it is the Device Label field, use that for your own name of the device.

When you go back to the list of Devices, you'll see that each has two names.. it's the LABEL that shows bigger and is sorted. Device name is the smaller font, below the Label. Often, having the manufacturer detail there is helpful.


I was using the wall switch to reset them all and to turn them all on during pairing mode. They all show up but I could only get one to persist when pairing ends. I would name them and hit save for each as fast as I could. I did see 'device' at least once on a known device fingerprint as it later came up generic zigbee rbw on a subsequent attempt.
Also any suggestions for my GE Z-wave plus toggle dimmer? I can't for the life of me get the one out of two of them working. They were successfully excluded from Wink and I tried several "factory reset" procedures (3 up clicks/3 down clicks x5 and 10 upclicks).

I understand.. so much voodoo involved. :slight_smile:

Here's the way I've found I need to do it... Open Live Logging.. Right click on Logs, click new Tab and you'll see an empty'ish logging page. Switch back to the other tab and start the Generic Exclude. (Settings: ZWave Details: ZWave Exclude button) then back to the live logs and watch it as you 'do the dance' required by the manufacturer. A successful Exclude will yield a log message of "unknown device excluded"

I'm back on track and took a backup. Still many more devices to go. Sorry for venting :slight_smile: Hopefully no more corruptions anyhow. I'll circle back to the GE Toggle Dimmers later. Fingers crossed.

FYI, much easier spot is to do it in the Device Discovery Page and Z-Wave now has an exclude button right there and will update when a device is excluded. That way you can also start the inclusion and pair it in the same interface.


This explains what I had the other day, we had a power cut in the morning and when I was working on it later that night it rebooted. Didn't lose anything large like OP but it's nice to know what it was.

I've caught up and more. I may have cut power to the hub but I thought it was in a UPS. I still cannot get the one GE inwall dimmer paired.
I'll try the other exclusion tip later. No screenshots from rookies I guess :persevere:

You want a screenshot of the exclusion in device discovery?

Here it is:

This can be used on any Z-Wave device, but keep in mind, general exclusion doesn't work through repeaters so the device has to be close to the hub to work.

A factory reset is preferred, since that is local to the device, and if / when successful the device should then pair / include assuming its in range and repeaters are working correctly.

No, I tried to post a screenshot of my progress. It says I can't put images in a post.
I have migrated most of my devices, 63 items so far, other than my Leaksmart stuff and my Wink Relay. I was finally successful with the stubborn GE dimmer after running the exclusion from the Wink again. Thank you for the help. Time to start automating.

I'd love to have live video / alerts from my ONVIF IP cameras and better Chromecast support if you're looking for ideas for improvement. To get rid of my HomeAssistant I need those to be complete. I need to replace a nice useful automation to turn on my Onkyo receiver in the basement when Chromecast is playing on the patio.

Thanks again for the help, as it turned out I had my HE hub in the surge only plug on the UPS and I likely did cut power to it trying to fix one switch. That probably corrupted the db. It it common to corrupt the db if the power goes out?

Rebuilding the smart home in the woods:
</screenshot not allowed again>

Somehow I managed to have my hub listed twice on the "Hub List". How do I remove the duplicate?

I did the same trick and you will need @bobbyD in support to help you.

Level Up!

Getting closer to having everything over including my Leaksmart valve and sensors. That went very smoothly despite being my first loaded drivers. I have control of my MyQ doors too but no status from tilt sensor.
The only thing left is my Wink Relay. Is it worth it to convert, reliable? Do I need root or can I just load the app? I've already customized my Relay with a few things for HomeAssissant but I don't think I rooted it. Coming along though.