Migrating a Z-Wave Network


Well... That didn't work. It doesn't offer a choice to pair at S0 or not... So unless there's some way to do this right in Hubitat, I suspect I may have to endure my unstable mesh until I get my Z-Wave stick...

Lewis Heidrick (@lewis.heidrick) has apparently figured out what is happening after a failed include, and how to fix. I had this same issue yesterday after updating ZEN16 firmware, and his solution worked, so I now believe.

Apparently two things can happen. First, if the hub can still ping a failed node, even if the device later did a successful,pair, you need to remove power to the device (so it can’t respond to pings), and then you will be able to remove the failed node. It doesn’t sound like this is your issue, because you haven’t been able to pair, but I mention it anyway.

Second, apparently the Z-Wave radio gets “borked” (saw that term used here yesterday) during failed pair attempts, and you need to do a clean shutdown to red light, then power down for 30 seconds, then power up and reboot.

Then try to pair again. I have rarely had success pairing unless the hub is 12 to 18 inches from the device. I understand that many devices go into low power radio mode to reduce the possibility of mesh snooping during secure pairing.

Hope this helps. If it doesn’t, we’ll, there is the Z-Wave stick.

Thanks @672southmain. He did help me with those ghost nodes that I had and it worked for all but 1 that I will need to remove with a stick.

What I'm hoping to do now, and maybe it's not a good idea, but I don't know any better... is to re-pair my S0 to none... Hubitat doesn't seem to have an "easy" way to do this... I've seen some hacks (start, remove battery, re-insert, etc.) but I would rather wait for the stick than attempt this 14 times...


Since I migrated to my C-7 hub, I am finding that one switch in particular has an odd behaviour. I keep losing the ability to send commands to it, though most of the time, I still have its status showing correctly when I toggle the switch.

It comes and goes, sometimes working, sometimes not... Right at the moment, it’s working perfectly. Seems the issue occurs mostly in the evenings.

The switch is an Inovelli Switch Red Series LZW30-SN paired with S2 security.

Has anyone else seen anything similar?

I don’t have this switch, but:

(1) I seem to recall that there has been a firmware update for this switch:

(2) have you tried without S2 security ? I.e., none?

I have firmware 1.20 on this one, but I see that 1.22 is available. I’ll give it a try in case it makes a difference! FYI, the latest firmwares can easily be accessed here as well:

1 Like

Odd that didn’t show up in my support search on the innovelli site for this switch.

I misread your question as about a dimmer, not a switch, so you can ignore my post.

1 Like

Yea, not sure where I found the link, but it is useful!

So I tried the firmware update, but it isn't working. And come to find out that I can't control the switch anymore... So I rebooted (Shut down, unplugged, restarted) my hub, left for a while, and now I can't control any z-wave device at all... I am really, really looking forward to everything working again on my C-7 hub!!!

The really odd thing is that the Z-Wave Radio Devices pretty much all have the "OK" status except a Ghost node that I can't yet remove (Z-Wave Stick on order...)

But then when I try running a Z-Wave Repair, every node fails: "Repair failed node unreachable"... This is the second time this has happened today...

@bcopeland, is this a known issue in Is there anything I should do to mitigate?

One thing to try: shutdown the hub. Then power it up again, and see if Z-Wave repair doesn't behave itself. Your symptom is of a crashed Z-Wave controller.

1 Like

Thanks! That's what I've been doing and you're right, it does work for a bit afterwards. It is what I did last time.

Unfortunately, it seems to crash again when I try to access this one light. I'm wondering if there might not be something within my mesh of that Inovelli switch (Firmware 1.20 when it was in beta) that is causing that...

The fact that none of these responded to a ping tells me that either something horrible happened to the mesh, or the SDK completely crashed.

He has a ghost node on there that is messing with the mesh.

Correct. Really looking forward to receiving that z-wave stick to fix it!!! Do you think it might be causing all those issues?


On the ghost node..

  1. Make sure the device is not online (not pingable)
  2. If the device is not in a failed state, click refresh on the node until it switches to failed.
  3. Click remove (sometimes it might require a second click of remove)

If the device responds during this, the SDK will refuse to remove the device

Would it be possible to put your hub and router on a UPS, throw the breaker for all other Z-Wave devices, then try to remove the ghost?

Unfortunately, I'm not sure which device it is... I tried removing the batteries/power to the devices after the ghost that I thought might cause it, but it still didn't work...

You know, that's a good idea, though I will need to remove a bunch of batteries too... At this point, that might still be worth it! I'll go ahead and shut down everything but the hub to see if it works!