Migrated From C7 to C8, now want to reuse the C7, what next?

I just migrated my devices from my C7 to my new C8, everything seems to have works just fine! Now, I want to reuse the C7 for Cloud integrations. What do I need to do to prepare the C7? Disable or Just reset the Zigbee ad Zwave radios? reset the hub??

  1. Do a soft reset without a restore.
  2. Reset the zwave radio, and turn it off.
  3. Reset the zigbee radio, and change the zigbee channel to be different from the C-8 turn it off. See this note from @Tony - the zigbee radio doesn't turn off.

This Up Here GIF by Chord Overstreet

Why is it necessary to turn off the Zigbee and Zwave radios....I want to use the C7 as part of a mesh setup...won't I need those radios in a mesh set-up???

You can turn on Zigbee and Z-Wave radios if you want to use them:

  • Zigbee on C-7 needs to be changed to another channel, different than the one your C-8 is on
  • Z-wave can just be turned on - no settings adjustments required, IIRC.
1 Like

Devices can only be paired to one hub. I have moved all of my devices over to the C8. Keeping the radios on the old C7 active won't help the mesh any, and since I don't need a second mesh it's just creating more noise. I will be using this old hub for cloud integrations like Ecobee and Rachio Irrigation controller.

1 Like

Don't know about the C-8 (mine is out for delivery today) but on C-7, even when in red light shutdown mode, with or without Zigbee 'Offline', the radio stays powered and the hub continues broadcasting (to the 'all routers' 0xFFF address) on whatever PAN ID and channel it was last configured. EDIT: confirmed that C-8 radio also cannot be turned off without unplugging power.

The only way you can actually turn off the radio is by pulling out the power plug. 'Disabling' Zigbee in settings won't do anything productive (with regards to unwanted traffic) unless you change its channel to one you won't be using first.


I believe that's why the recommendation is that you either turn it off and unplug it, or if you're going to use it change the Zigbee channel on the original hub.

Does it matter what channel? or just different from the C8?

I agree; only mentioned it because many of the recommendations are to turn off the Zigbee radio (which cannot be done) and don't include the 'change the channel' part. You can actually leave Zigbee online (that setting doesn't affect the radio emissions) as long as you remember to change the channel to one that your other Zigbee hubs won't be using.

Btw, running the sniffer today I found two additional Zigbee PAN ID's in range (on channels I thought were unused) that I never knew about. One is probably my old Wink Relay (I think those things could host Zigbee devices without a Wink hub); the other might be a neighbor's smart meter (mine is non-smart). Impressive range, if so; I can barely detect their wifi access point. That's on top of the Zigbee channel that the Echo Show 8 is running.


Different from the C8, and ideally not conflicting w/your 2.4ghz Wi-Fi channel...see below for more info on that:

Also note comments on that page about 26 not being the best Zigbee channel:

ZigBee channel 26 is usually relatively unaffected by Wi-Fi, but many ZigBee devices do not support it. And IIRC, Channel 25 has a lower transmission power in the US due to FCC regulations.

How are you going to set up those integrations on the C7?

Copy them manually over from the C8 and then disable or remove them from the C8?

I'm looking to do similar with some things, just haven't figured out how far I need to take it (i.e. Maker API stuff for Home Assistant and SmartThings, IFTTT, HubiThings Replica).

Currently I don't have Rachio integrated at all, and Ecobee is actually on my Apps hub. Ill just remove it from there then se it up on the newly vacant C7, along with the Rachio. But first, apparently none of the devices that were ported to the C8 are recognized by hub mesh, so none of my rules are working. Looks like i'm either going to have to remove and re link all the devices and/ or rebuild all of my rules again. Either way its going to be a while before I get to the cloud stuff.

Try this first... Update option under hub mesh.

1 Like

Too late. Last night I was having a similar problem, went through and manually linked all the new devices, and used Swap Apps Device then removed all the devices from the old links. By the time I read that today there was nothing there to update. I'm still having issues with devices from the C8 that are hub meshed not being recognized by the C7 with all my rules and automations. I estimate about 60% of my rules and automations aren't working currently.

This is the only option it gives me, the C8 both as source and destination.

1 Like

Is there a way of doing this that won’t affect the Zigbee mesh? When I turn my C7 back on will it interact with the devices that are now talking to the C8?

I've sort of answered my own question.

Booted up the C7, hit the 8081 page while it was booting and selected soft reset.
Once it had been through that process checked the Zigbee page - no devices listed, hit reset anyway, and changed the channel to 15.

However, and I'm not sure which of the following two things caused it, but I've had 3/4 of my devices drop off the C8. It was either trying to add a Aqara device (that was originally paired to the C8) to the C7 (without success), or it was changing the signal strength from 8 to 16 on the C8.

I've just about got all the devices back on the C8 after going around and repairing them again - apart from a couple which are being stubborn. The C7 is shutdown again until I understand what went wrong.

Bringing the c7 up with the same zigbee id prior to the radio reset as the c8 since you did the migration could have caused an issue. You can try shutting down the c8 and unplug for 25 mins to throw the devices into panic mode and bring it back up and see if that helps.


Thanks, I’ll give that a go tomorrow during daylight, and the kids are at school :slightly_smiling_face:

1 Like

It had to wait until the weekend. The step I’d missed was resetting Zigbee properly. No clash with new Pan ID and channel changed to 15. I have some IKEA sockets as repeaters, and a bunch of Sonoff contact sensors, running on the C7 and meshed to the C8. Will be interesting to see if they behave. The one I tested some time ago would drop off after a week.

Download the Hubitat app