Migrated C-5 to C-7, Schlage BE469 locks don't work

An exclude typically has the same results as a factory reset, all settings are cleared and reset.


While you shouldn’t have to.. If the device supports S2 it will be a much better long term experience..

Now the device isn’t showing correct security in z-wave details, which would account for the devices not operating properly..


Thanks everyone. So I will:

  1. create virtual locks for each lock, use Habitats swad device in rules function to swap it in for my physical locks
  2. try and exclude the locks in place, if they exclude cleanly the first time, I will try pairing them in place but if that doesn't work then figure out a way to get them close to the hub
  3. once all locks are included with new security, swap them back in to my rules in place of the virtual devices.

Man, the hubitat video made the migration using hubitat protect look so easy! I think they need to add a few caveats! :stuck_out_tongue_winking_eye:

Let us know how it goes. I have 2 Schlage locks that work perfectly with my C5, and I have a C7 laying by as backup I've been meaning to migrate to, so would appreciate your learnings as you go.

FYI - There is also a related thread on the built in driver v.s. custom where some firmware/versions of schlage (seems like the BE469NX) might be acting up. For reference my two are BE469ZP

Just for reference, I did a manual migration of everything from my C-5 to my C-7 back when the C-7 first came out, using Bruce’s (@bravenel’s) manual migration guide Migrating a Z-Wave Network

At the same time, I swapped out the electronics modules for our two BE469NX locks with BE469ZP modules so as to get S2 pairing. They work fine for me, but I have a Ring Extender v2 (beaming) near each lock. As a note, changing the modules also extended the battery replacement time from about 2 months to about 8 months due to the lower packet traffic with S2.

1 Like

So far, not going smoothly. The first lock did actually exclude in place but then wouldn't include in place. The other 2 locks won't exclude in place. So now I either need to remove all the locks and take them close to the hub or track down a long ethernet cable to get the hub close to the locks to exclude and include them. Not fun. Had I known this before upgrading to the C7, I would have just stuck with the C5.

How do I pair one of my locks using S0 security rather than S2? One of my locks I bought 2nd hand to replace a failed lock and it didn't come with the S2 security code. This wasn't an issue on my C5 hub but now can't seem to pair it with the C7 hub.

I've tried selecting pair with no security and I've tried pairing with security and then pressing skip when it asks for the S2 code but neither work. I just end up with a ghost node.

There is a third option: knock out the hinge pins and bring the door to the hub. Quick and easy.

Make sure you remove that ghost node before proceeding further. Doesn’t hurt to shut the hub down, remove hub power at the wall (not at the hub), then reboot. That’s the only way to reboot the Z-Wave radio.

Thanks for that suggestion. I've removed the first lock already and have it within inches of the hub but don't have the S2 code and can't get it to pair with S0 security instead.

I believe that there is a way to get the hub to reveal the DSK key during pairing, but my old brain can’t remember the dance. Perhaps someone else could remember. There is a sticker on the inside back of the lock that has the key, but you have to take the lock off to see the sticker.

The sticker on the back of the lock has the programming code but not the S2 DSK code unfortunately. If there is a way to find the DSK code during pairing that would be amazing.

There is, and it’s here in the forum but I can’t find it. I seem to recall that it involves choosing a different option during pairing (unauthenticated ?} And observing the then-displayed DSK. Problem is, the UI was changed several times during development of the S2 pairing.

Yes seems that was an option on previous firmware but now there is only the option to pair with security or pair without security and neither of them are working. I get a message saying it's bootstrapping security and then eventually the inclusion times out and I have a ghost node.

No, DSK is on the back of the lock mounting plate, against the door. Not the sticker with the programming codes.

Unfortunately no sticker on the locking plate either. I checked both sides even. Really silly on Schlage to not put it on the actual lock.

I find this error in the logs: Z-Wave device id: 86 failed S2 bootstrapping - KEX_FAIL_DECRYPT: Node failed to decrypt received frame. - the device needs to be excluded then included again to use securely.


Problem solver!

1 Like

If the mountain won’t come to Mohamed …..

1 Like

Ok, the 2 locks that I have the S2 DSK codes for excluded and included no problem but I cannot get the other lock where I don't have the S2 DSK code to pair.

Any help on how to pair it just using S0 or, preferrably, how to find the DSK code during the pairing process now that the new hubitat firmware just gives 2 options (pair with security and pair without security) would be amazing and put this issue to rest for me!