Mesh issues ***SOLVED***

I added an extra hub to create a mesh environment. this worked fine for 1 day. after that it keeps giving a token error. the devices are offline.
I placed the token a few times. I rebooted both hubs. disabled mesg rebooted and re-enabled mesh, rebooted. same issue.
they should have the same version, but diagnostic shows an strange issue

mesh issue is solved ( fingers crossed for the long time)
certificate ssl issue. ssl only needs to be turned off.
with this turned on, I oalso could not get settings/networking to work. this gave an error.
errororg.codehaus.groovy.runtime.InvokerInvocationException: PKIX path building failed: unable to find valid certification path to requested target (mainPage)


the difference in the diagnostic tool, is still there. even after a "soft reset" and restore..

Did you link the hubs? Or are you using hub mesh app to share devices?

As far as the differing diag tool versions, you could try upgrading again, after a downgrade first, looks like the diag tool didn't update properly

I am seeing exactly the same thing under the same conditions. I have a C-7 and a C-5, both running, both show Diag Tools version 1.0.92. Two days ago I received another C-7 (gosh, Mail is slow, 8 days for Priority Mail), came with and Diag Tools 1.0.75. Registered it, updated firmware to, Diag Tools stayed unchanged at 1.0.75. Even tried the endpoint:


No change. Let sit two days idle overnight to see if Diag Tool updated on its own, nope.

Just now tried your suggestion to roll back (to, the only choice because it’s a new hub, then update again to Diag Tool stayed unchanged at 1.0.75.

I don’t believe that there is any connection between firmware updates and Diag Tools update, but I tried your suggestion anyway.

was a shot in the dark. I guessed they were rolled into same firmware package, and I guessed wrong.
Hmmm, now curious how diag is updated, if not connected to hub firmware

A week later, my new C-7 has updated itself to Diag Tools 1.0.92.

Ok, so there's something about new (unregistered?) hub setup that prevents it from pulling a new diagnostics tool. I'll check that out.

There's a once-a-day check in hub software, but it's not "reliable", i.e. there are no built in retries. The assumption is that there's already a functional diagnostics tool on the hub, and the update will succeed eventually.