Maker API - push a button with a secondary value?

I am trying to use Maker API to push a numbered button on a minimote or other virtual button device.

http://[hub ip]/apps/api/404/devices/160/push?access_token=[token] hits the correct device with a "null" button press.

http://[hub ip]/apps/api/404/devices/160/push/[button number]?access_token=[token] using an optional value with the button number does not work:

Does Maker support buttons with secondary values? If so, what am I doing wrong?

Hitting the whitelist issue. In an upcoming release we are going to remove this and allow any command to be sent to authorized devices.


Perfect, thanks.

Any news on that update?

That came out a LONG time ago. You can send any supported command to the maker API. It was fixed later the same month that this post was posted, about 16 months ago.

Okey, I'm trying to push a button controllers button via maker api and via te cloud link

Lan link is working:

Cloud link does not:

FYI the links in this post have fake tokens :wink:

I don't understand what goes wrong here...

Any help is appreciated, thx

Do you have the maker API enabled for Cloud Access? What is the error that your are getting in your browser or in Hubitat?

Hi, cloud/remote is enabled and it works with other stuff, and has been for a year.
I get a 500 error if im not remembering wrong, ill check it tomorrow

Remembering? You mean you didn't just try this? Because all commands have worked from the maker API for almost a year and a half. Including custom commands, which couldn't possibly be on a white list. Trust me....this works.

I tested it 2 days ago and didnt remember, I restarted my hub today and tested it again, now it works perfectly :smiley:

I dont know why, I'm blaming the corona situation for my lack of focus when testing it the first time :slightly_smiling_face:
Working from home with 2 small children can do that to you hehe.

@Ryan780 Thanks for helping me

1 Like