Maker API local endpoints no longer work with local Flic hub

There have been a number of Hubitat updates in the last couple weeks... after one of them, my Flic buttons (connected via the Maker API) stopped working. I just figured out how to get them to work again: I had to enable cloud access and add the cloud endpoint URL to the Flic internet requests.

This bugs me though, it used to work just fine locally. The Flic Hub and the Hubitat are not only on the same ethernet network (with IP addresses in the subnet), they're also on the same WiFi network (the primary WiFi, not the guest WiFi). Why are my local endpoints suddenly not working?

The local endpoints work fine if I paste them in a browser window on a device on the network.

Edited to add: I also upgraded my router firmware somewhere in this mix, but the Hubitat IP address is fixed and didn't change. I don't know if the Flic hub IP changed, but that shouldn't matter as long as they're on the same subnet.

AFAIK, none to MakerAPI.

They should. I make use of four local MakerAPI integrations (two homebridge, two node-red), and they all still work like they used to.

1 Like

That will matter if the Flic MakerAPI instance is using a postURL to send events to the Flic hub. And I'll bet you that's why the cloud endpoint works. Because the IP of your Flic hub changed.

It's just a GET request, not a POST request though? Here's a sample URL:

Does that integration not require the MakerAPI instance not send events back to the Flic hub?

No, you trigger the Hubitat actions by simply visiting the URL. Which is why I'd really like to keep it local, even with two tokens (one for the cloud, one for the Maker API).

So there are no events sent back to Flic. Then, I am at a loss as to why a LAN integration that used to work, has stopped working.

There's no accidental mismatch in the access-token, right? Someone else had that issue in the last couple days.

Well, at least it wasn't something stupidly obvious I guess. No, the token is fine, I copied and pasted the "list all devices" link from the Maker API during testing, and it only worked via the cloud as well.

No new VLANs or firewalls?

Not that I'm aware of. The router update was minor, just load and reboot. All the settings should have remained the same.

The other hubs integrated with the Hubitat on the network appear to be working fine (Hue for example), but they don't use the Maker API.

I don't see any way to update the Flic hub. I hadn't touched it until after it stopped working, after which I tried "rebooting" it (unplug, wait, replug).

Thanks for brainstorming with me...

1 Like

I would check if your router has had any settings changed. Unless you have a router config backup, that might be difficult.
I no longer use standard routers, but from when I did I recall that settings could be updated(security reasons) during a firmware upgrade &/or not restored properly after the firmware flash.

just for fun, check your UPnP setting in your router