Maker API errors

@patrick @bravenel @chuck.schwer @mike.maxwell @bobbyD

Did the maker api whitelist get reinstated?

I'm working on a device driver which sends custom commands to a custom device (on a second hub)

If I send a standard 'setLevel' command via Maker api then everything works ok and I get the correct response.

But.. If I send the 'speak' command or a custom command to a device that has that capability/command then I get this error message:

There is no remove() method in anything I'm using.

I've tried a number of 'custom' commands (where the device has the command) and I get the same error


There have been no recent changes to Maker API, did this work before? What happens if you do /speak/test instead of 123?

I have only just tried it.
speak/test as the value didn’t work either.
It gives the same error


I have no idea where the remove() method comes from

I still get the same result from any custom command


Is the maker api capable of sending custom commands or is it just the 'standard' commands (e.g. on/off, open/closed etc)

I'm really struggling trying to get a custom command sent


@Cobra did you ever get an answer from @patrick on this?

I didn’t but I found a typo in my code.
I now have a number of custom commands defined which seem to be working.