Maker API Error in log

I am getting this error message in Maker API, I am using it with node red. I've tried to see what's up by shutting off all the flows and deselecting all the devices and it still throws the error.

I get that problem when I remove a device from Maker API but still have a Command Node for that device in Node Red. Go to your RPi Terminal and run node-red-log and wait until it happens again. Then, you will see what Node Red is logging at that exact moment as the error in HE.

I don't know if Node Red stores past logs so that you could go back when you don't have node-red-log running in Terminal but the experts can probably answer that.

1 Like

Another thing that can cause it is if you have a msg.deviceId going into the command node that you're not expecting.

I've had a few times where upstream nodes would use that same parameter value which will then override the device when it gets to the command node. And if it specifies a device ID that isn't valid you will get an error just like that.

Unfortunately, a lot of other things can cause that same error message too though.

Unlike the device events, the command node does not log every time it executes a command. so likely all you will see in the node red logs is a not very useful javascript error.

it would show which node caused the error though, which can be useful at times.

Yeah, I can't remember if it was usually rogue Device or Command Nodes I left in Node Red that caused my problems but my suggestion has been solid finding out the problem when I break things.

And I have had to do this many times unfortunately.... :grinning:

1 Like


So you don't feel all alone:

And I didn't have node-red-log running so I don't know what that is.... yet.

EDIT: This is the error that shows up in my node-red-log. In my case it's a Tasmota Node MCU that sends MQTT message and then I have commands to set temperature, lux, and humidity to virtual Omni Sensor in HE based on MQTT message received. I have 2 and they will sometimes generate this error. In this case, it was node circled in red. I haven't noticed any issues otherwise and the error happens randomly so I ignore. It does look like it's a Command issue though based on text in the error message.