LZW30-SN (2x) not responding to inclusion requests

Crossposting (also posted in the Inovelli forums)

I recently upgraded my Hubitat to C-8. "Most" of my previous attempts at firmware updates on the Inovelli(s) on C-7 had failed, so, I decided to give it another run on the new C-8. I realized that with S2 Authentication, the firmware updates were still a no-go. I excluded/re-included a couple of switches with Auth=None and then the following:

Sequence of events

  1. On a LZW30-SN, update firmware using C-8 | App = Firmware Updater
  2. The process takes 90 minutes and then finishes
  3. Once Done, the device works fine & responds to hubitat interactions
  4. Stops working after a few hours, automation starts to fail
  5. Tried excluding, did not work, had to force remove
  6. Tried inclusion, did not work
  7. Did the 20 sec factory reset
  8. Re-tried inclusion, did not work
  9. Switch works manually, led responds (factory reset/inclusion/exclusion)
  10. Many airgaps included in the above after step 4

As if one failure was not enough, I tried a second switch and landed the same situation - yes, I know, I should not have. :slight_smile:

Any advise on how to revive these switches.

I found a couple of devices in Zwave Details that are in PENDING status. I am not able to remove them. Are these unresolved references to these devices causing my problem with not being able to exclude them?

[sys:1] 2023-03-05 07:10:13.453 PM
[info] Failed node 4F remove status: 
0 SDK failure node is no longer in failed node list

[sys:1] 2023-03-05 07:07:03.255 PM
[info] Failed node 56 remove status: 
0 SDK failure node is no longer in failed node list

When I run Z-Wave Mesh details, here is what I see


Update: Turns out this is due to "ghost" devices in the zwave details. On one of the switches, I was able to hit "refresh", cause it to surface the "remove", and then remove it. After that inclusion worked on that switch.

Now, I have a situation, where I have two "ghosts", any amount of "refresh", "remove" or even "reboot hub", "refresh", "remove" and even "remove" while air gapped, is not working.

How long does a "ghost" live in PENDING state? Any other ideas?

If they don't remove over the course of a day or so then you will need to use a z-wave stick to remove them. Ghosts can really hamper your mesh.

1 Like

Thank you, @rlithgow1! On the z-wave stick method, I do not have a windows machine at home, are there alternatives?

If you have a mac, install parallels (free) and install a demo copy of windows (free) share access to the usb port to the VM

1 Like

try this excellent doc

1 Like

@rlithgow1 @Rxich - Thank you very much! I got a zwave stick, installed parallels, windows 11, simplicity studio, zwave pc controller .... and was able to successfully remove the two ghosts using this document @Rxich shared. Again THANK YOU!

@bcopeland @bravenel - If this is possible with a complex contraption :wink: why is this not possible through the hub? While as a geek this was somewhat exciting to do, the barrier to doing this is so high!!

Because you're bypassing the SDK for lack of a better description. If Hubitat were to somehow build this in they would risk losing certification. Post your current z-wave details page lets see how it looks now.

Hey Rick, so does this imply the Aeotec stick is not Z-wave + certified or is PC-Controller not Z-wave+ certified or both?

1 Like

@rlithgow1 - here it is ...

Well your mesh looks good in general now. :slight_smile:

1 Like

@rlithgow1 - yes, sir! Also, I was able to go from two C-7s in a mesh to one C-8 with many more devices connecting directly to the hub!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.