Lutron Thermostats suddenly read-only (edit: for temperature only)

I haven't added anything device-wise or app wise to my Hub in quite some time. I have 4 RadioRa2 thermostats in my home and everything was working fine with connecting them to my C7 for months, but recently, they have basically become "read-only" devices. What I mean is, when I make a change at a thermostat or in the Lutron Connect app, all of the values properly show up in my Hub Dashboard/Devices. However, if I make a change in the dashboard or on the Hub device page or in Alexa, they don't get sent to my RadioRa2 system. Here are a couple of logs:
image
The above were setting the temperature in Alexa, Dashboard, and on the device page, respectively.

These are the Lutron Telnet logs from the same time, you can see that when I changed the temperature in Lutron Connect, it was received, but nothing was ever sent for the above commands. Any thoughts? I'm running 2.2.6.140
image

I should note that everything is working normally with all of my other Lutron stuff (lights, shades, etc.).

1 Like

More tinkering:

Setting modes and turning on/off the fan work fine. It's literally just adjusting the temperature that's not working. I just turned on the "use telnet direct" toggle and it hasn't changed anything.

And yet more tinkering:

I also have a C-5 and added the thermostats to it to see if there was something wrong with my C-7. Exact same behavior, so it seems to be something in the latest firmware that's causing the issue.

I have two of these, and am not seeing any problem adjusting setpoints from an app or device page.

Please go into the Lutron Integration app and hit Done. Then try again with just the device page for one thermostat. Change one of the setpoints, and show the Lutron Telnet logs that result.

That didn't seem to do anything. Here is the log.

Starting from the bottom, I opened the integrator and hit 'Done'
I attempted to set the set point to 75 (it didn't do anything)
I turned the fan on (it worked)
I turned the thermostat to off mode (it worked) (accidentally did it twice)
Set the fan back to Auto (it worked)
Set the mode back to heat (it worked)

image

That's very odd.

  1. Remove the device. This will also remove it from any apps that use it, and those will have to be updated later.
  2. Open Lutron Integration app and hit Done. This will create the device again.
  3. Try changing a setpoint.

Show the Lutron Telnet logs again.

So I was trying to avoid that because I have a bunch of rules on the C-7 and routines in Alexa that I didn’t want to deal with. That’s why I tried adding it to my C-5 (fresh add just this morning - it had never been on it) and had the exact same thing happen. I’m away from my house right now but i guess I’ll try your suggestion when I get back, but in light of the C-5 experience, I’m not hopeful.

Another thing to try instead. Open the Lutron Telnet device. Send a message to set the setpoints.

HVAC,32,2,72,75

That should set both setpoints. See if that works.

Literally nothing in the Log when I tried your suggestion.

I didn't have debug logging enabled. Here is the log (but nothing changed - the HVAC received was a different thermostat that coincidentally kicked on before I took the snip):

OK, so it appears that the thermostat is not responding to a command sent via Telnet. There is one more way you could test that. Open a terminal app on a PC or Mac, and connect a Telnet session to your main repeater. Give that same command there (this takes Hubitat completely out of the picture). See if the thermostat responds then.

2 Likes

So the telnet commands actually work fine (not withstanding the one invalid command I attempted to send):
image

I just tried the Hubitat Lutron Telnet command again this time with the '#' in front of the string and it worked (sorry if it was implied that I should have put that there in the first attempt), but I still can't use the device or dashboard.

OK, This is weird now:

  • The Set Cooling Setpoint command works fine (and the related Dashboard Tile)
  • The Set Heating Setpoint command still doesn't work...
  • But if I send a heating setpoint either on the device page or in the dashboard and then immediately send a cooling setpoint command, both the heating and cooling setpoint commands get sent and are received by the device

In this snip, I set the heating setpoint to 65 (it does nothing), then I set the cooling setpoint to 75, and it updated both the heating and the cooling setpoints.

Where are you doing this? On the device page? In an app? On a Dashboard?

Please show what you mean.

All of the above. Refer to this screen recording:

I really can't tell what you're trying to show with that video. It pretty clearly shows that when you change the setting of the heating setpoint, that command is sent to Lutron, as evidenced by Lutron sending back the confirmation:

Screen Shot 2021-04-24 at 12.14.27 PM

So I'm completely missing what it is that you think is not working as it should. Please, instead of 3 variations of the problem, just keep it to a single example. More is not helpful, just confusing.

I'm showing you that every time I adjust only the heat, it does nothing at all. The heat doesn't adjust until the cooling is also adjusted. Here's another attempt to show you what's going on using only the device page. Note that, according the log, when I send the heat set point, there is no response from Lutron. Only when I send the cool set point do I get a response.

When you told me to show you what I meant and asked what methods I was using, I thought you wanted to see all of the ways and the result. In the first video, I first try with the dashboard, show the log showing nothing happened. Then I try adjusting it on the Device page, again nothing happens, until I set the Cool Setpoint, then the messages are successfully received by Lutron.

Here, I figured out how to narrate the video for you so I describe what I'm doing while I'm doing the screen recording.

In the Lutron Integration app, do you have the 'Use telnet direct' option turned on? If not, please turn it on and hit Done in the app.

Download the Hubitat app