Lutron Thermostat Setpoint vs Heating Setpoint

This is kind of weird: I have Lutron (Ra2) Thermostats that I am trying to control with the built in Dashboard Tile/Device page. When I make an adjustment, it changes the Heating Setpoint Attribute (3rd bullet below), but it does not change the Thermostat Setpoint Attribute (last bullet below and this seems to be the one that matters to actually control the thermostat). I'm wondering if this is maybe a bug in the Lutron Thermostat driver. The attributes below are the states after the log events.

So in summary: the driver and the tile only let you adjust the heating/cooling setpoints, but there is no ability to adjust the "thermostatSetpoint," which is the only attribute that Lutron actually cares about.


Tagging @bravenel.

Which Lutron thermostat device are you using?

I have 1 SeeTemp (LRD-WST-F) and 3 TouchPros (LR-HWLV-HVAC). Same behavior for all.

Also of note: while the above error message appears in the thermostat device log(s), nothing appears in the Lutron Telnet log when I try to adjust the setpoint via the Device Page or Tile.

try using the Lutron HVAC controller driver.

1 Like

Nice. That worked. I now remember from ~a year ago seeing both and wondering at the time what the difference was (but back then, the Thermostat driver worked for me, so I just stuck with it).

Do you know when we're supposed to select each one?

i think the thermostat is for the standalone thermostat, not the controller with the seeTemp units...

1 Like