Lutron Scenes not activating in rule

I created a Lutron Virtual Keypad device via the Lutron Integration app. I created a scene in the Lutron app which turns my two garage lights and another scene that turns these same lights off. The Lutron Integration report lists these two scenes as button 1 and button 4.

The scenes are activated perfectly via virtual buttons 1 and 4 when I use the Lutron Virtual Keypad (from the device page).

But when I try to do this in a Motion Lighting rule, the scene does not activate (the lights don’t turn on). The logs say “not turning on, already on.” However, the lights are NOT already on.

Here’s my rule:

How is this connected to your Lutron system? Are you using Caséta? The Lutron Integration app only creates devices that correspond to actual devices in the Lutron system, or phantom buttons (scenes) on the bridge. Please explain.

I have Caseta switches and I can control them from the Lutron Virtual Keypad Device (from the Hubitat device page).

Turn on logging for Motion Lighting app. It will tell you in the logs what it is doing.

OK, but you didn't answer my question. Is this the device with Integration ID of 1?

@bravenel The logs say “not turning on, already on” but in fact the lights are off.

Yes, ID is 1.

As a temporary thing, include one of the switches in the app as a switch to control (it's ok that you will be controlling it two ways). Hit Done in the app after you add the switch. See if that makes it work as you expect. If it does, then when the lights are off, remove the switch from the app and hit Done again.

Either that, or just remove this instance and create it from scratch. If you had the switches in it before and removed them to use the keypad instead, it got confused about the state of the lights.

By “remove this instance”, does that mean delete the rule?

I added the switch to the rule and it works as expected. I turned the light off, removed the switch from the rule, hit done, and still the same issue.

Also did this:
I deleted the rule and recreated but it still doesn’t work and the log still says “not turning on, already on.”

I deleted my Motion Lighting rule and re-created it in the Basic Rule app and now it works!

I’m very sure both rules had the same, correct parameters, so I’m confused why it works in one but not the other.

Download the Hubitat app