Lutron Radio Ra2 Keypad not triggering events

Hi there - I’ve created a button controller that should take the input from a Radio Ra2 tabletop keypad, and toggle a virtual switch. However, I can’t get this to work. I’m still new to Hubitat, so I’m sure it’s a simple fix, but would love some advice.

I can see in my logs that the keypad is generating events, but these events are not causing the button controller to activate, nor is the button controller generating any log messages.

Somehow, I’ve either not gotten my integration working properly, or I have not programmed the button controller properly.

My logs look like this when I press the keypad button:

I’m pretty sure my integration is good, as I am able to control other Radio Ra2 dimmers and I am able to send “press button” messages from the device page, and the correct corresponding buttons are pressed on the keypad.

I’ve tried a basic rule, button controller, simple automation, and rule machine, and I can’t get ‘input’ from the keypad.

Thanks for any thoughts!

I’m not familiar with the RA2 Keypad, but have you tried using “Custom Attribute”, selecting the Keypad and seeing if there is an option that works?

Can you show the integration line from lutron integration that contains your keypad?

@rlithgow1 Thanks so much - my integration line for this keypad is “k, 30, Primary Bedroom”

@Sebastien I will try a custom attribute to see if I can get that to work.

1 Like

So set your scene within the lutron app itself, attach specific keypad button on the lutron app. Then use hubitat button controller to push the button. (this will also avoid popcorning)

So your button controller should look similar to this

I’m actually trying to do the opposite - I want to use an unprogrammed button from the keypad to control a non-Lutron device (a virtual switch).

I did find one error - my integration line had spaces in it, so I changed the “ k, 30, Primary Bedroom” to “k,30,Primary Bedroom” and now my logs look like:

This looks better, as it seems that Hubitat is now registering that the button was pressed, but I still can’t get this to work as a trigger. I will go back and do some more investigating.

1 Like

So first make the button control under button controller. Then use button controller as trigger in rule. Now that it's registering correctly in logs it should work

Thanks again for the help- but even when I use the keypad button as the trigger in a rule, a press of the physical button does nothing. I must be doing something very simple wrong.

Start with the device page for this keypad. Press the button there, and look at the logs.

When you hit the physical keypad, look at the Lutron Telnet device log, and be sure that the keypad is actually sending its command to the hub.

The log entry would be along these lines:

[dev:864] 2022-03-27 10:17:02.519 am [info] rcvd: DEVICE,27,4,3

That was for button 4 pushed -- the 4 is the button number, the 3 means pushed, and 27 is the Lutron id for the keypad

Thanks so much. Pressing the virtual buttons on the device page generate log messages that are identical to the log messages generated when I press the physical buttons on the keypad. So it SEEMS like the device and integration are working. But that’s where things stop- nothing from this keypad seem to work as triggers.

Please show the logs for the device itself when you press the button on the device page, and show the rule that doesn't trigger as you expect.

This is what the log shows when I virtually press a button on the keypad device page:

This is a rule that I made to test this out, which doesn’t trigger:

Hit Update Rule, then show Event Subscriptions from the App Status page (gear icon).

Thanks so much. I did this, and I’m now looking at the Event subscriptions, and here is what is listed:

I don't see any reason that shouldn't work.

Let's try an experiment: Create a Basic Rule for same button, turn on logging in that rule, hit Done, and see if it fires.

Thank you. I created the basic rule below, but agin, nothing shows in the logs for the rule and therefore the rest of the rule doesn’t happen. The only log is as above, showing that the Lutron button was pressed.

image

Try these steps:

Remove the Hubitat device for the keypad. Open the Lutron Integration and verify the Lutron ID for this keypad is correct, and then hit Done. That will recreate the device. Recreate one of these apps from scratch and try again.

That did it. This device is now triggering as expected. Now I know a troubleshooting technique: delete the device completely. (I had just gone back to the Lutron integration app and checked the entries and clicked done before WITHOUT first deleting the device.)

Many many thanks all around.

2 Likes

Download the Hubitat app