Lutron Pico, HubConnect, and Smartthings help needed

I am stuck trying to get my lutron pico to control my smart shades and hoping someone can help me get unstuck.

I have the Lutron hub connect to Hubitat (Works great, all commands are coming through).

I have Hub Connect installed to connect Hubitat and Smartthings (Is working great for sending status from Smartthings to Hubitat. I have dimmers and switches and this all works).

I have my Soma Smart Shades connected to Smartthings. All controls from Smartthings works.

My goal is to use the Pico and depending on the button pushed have webcore trigger multiple shades to open, close, and set at a specific level.

Before anyone states - why don't you move everything to hubitat or smartthings, I can't. I tried every configuration that I know of and I kept hitting issues. Soma Smart Shades seem to only work well in Smartthings, the Lutron Hub with pico's only work well in Hubitat. I tried using hubconnect with the smart shades, but all the commands/actions don't translate well over hubconnect. The only way I could raise/lower the shades correctly was to have the shades in Smartthings and use logic with Webcore in smartthings.

My problem is that the pico button push from Hubitat is not triggering correctly in Smartthings. The command is being sent and it is received through hubitat on Smartthings, but its not actually triggering the button push in smartthings. This causes webcore not to trigger.

Here are the commands from Hubitat from the Pico
dev:1262021-03-07 10:33:21.231 am inforcvd: DEVICE,2,2,4
dev:1262021-03-07 10:33:21.111 am inforcvd: DEVICE,2,2,3
dev:1262021-03-07 10:30:33.007 am inforcvd: DEVICE,2,2,4
dev:1262021-03-07 10:30:32.820 am inforcvd: DEVICE,2,2,3

Here is the data from Smartthings to show it is receiving the status.
10:49:56 AM: debug Received event from Server/Living Room: [pushed, 5 , isStateChange: null]
10:49:52 AM: debug Received event from Server/Living Room: [pushed, 1 , isStateChange: null]

Here is the device in Smartthings

Living Room Device Living Room

Name Living Room
Label Living Room
Type HubConnect Button
Version Published
Device Network Id
Last Activity At 2021-03-07 9:42 AM EST
Date Created 2021-03-07 9:42 AM EST
Last Updated 2021-03-07 9:42 AM EST
Data No data found for device

Current States
numberOfButtons: 5
Execution Location Cloud
Events List Events
In Use By
webCoRE / Shades (webCoRE Piston)
webCoRE / webCoRE (webCoRE Storage)

I feel like I'm missing something simple. Has anyone gotten button's to work correctly from Hubitat to Smartthings? Hopefully I'm missing something very simple.

I installed the Hubconnect Smartthings driver. (the universal driver kept erroring out stating I was missing a "push" capability")