Lutron Pico button double tap?

Hello -

I'm wanting to have one of my Lutron Pico remotes do something when I double-tap or hold one of the buttons. I thought this was possible in the old button controller, but now that's been retired and the only 'triggers' I see for the button devices in Rule Machine are 'pushed' or 'released'.

I tried installing stephack's Advanced Button Controller (ABC) because I thought I saw a post about someone doing this using ABC, but all I see in ABC are 'pushed' and 'released' - no held or double tapped.

Am I missing something in Rule Machine or ABC? How is anyone else doing this using Lutron Pico remotes?

During the initial rule creation, pick button device from the trigger.

Sorry, I think I incorrectly used 'trigger'. I meant 'button action'. So, when I make a new rule, I select 'button device' as the trigger, then I select the Pico as the button device, then select the button number, and then for button action, my only two options are 'pushed' or 'released' - and I'm looking for double tapped or held.

You'd only get "double tapped" as an option in Rule Machine/Button Controller or ABC if the button implements that capability. No native Lutron Pico driver ever has, but other devices you may have seen do (SmartThings Button, lots of Z-Wave scene switches, etc.). Also, the Fast Pico driver doesn't support "held" if that's the driver you're using; only the regular Pico driver does. I suspect that's the issue here, though you may also notice the above if you create a rule starting with one button device and then switch it out for a different one or add more (RM doesn't refresh the number or capability of the buttons, so you're stuck with what the original device had; creating a new rule works around this).

However, you could cheat to get around this if you want. You could use a local variable to alternate the press number between 1 and 2. Theoretically, the rule's Private Boolean could do the same, but I think that's a setting rather than an item in atomicState, so if you double-tap the button quickly (twice in a row like you mean it, as one might do when double-tapping), it's possible that won't update fast enough. I wouldn't count on atomicState to necessarily be super-fast either (give it at least a fraction of a second before you try again), but at least the value should be accurate when the rule runs the second time. (This is really an app implementation detail you don't have to worry about, but my advice is to use a local variable instead of PB even though they seem similar.)

I also wrote Dimmer Button Controller for a slightly different purpose (to emulate multiple presses of a Hue Dimmer's "on" button--or any similar device like a Pico--in Hubitat to rotate through different scenes/settings like it can on Hue), but if you only use that for up to press 2 it might do what you want.

1 Like

I don't know if my pico's are different but I have more options in Rule 4 with newly (august 2019) purchased pico (bundle switch + pico):

this is a sample of a rule I set, without installing any app but the built-in HE Lutron App. I have other choices for any of the 5 buttons, like pushed / held / double Tapped / released

*Edit: tested a rule 4 with held button 3: worked (and in this case, a simple push has no effect)!

What would matter is the Hubitat driver, and none for the Picos expose a DoubleTapable (sic.) capability. What you're seeing is because we're actually talking about different things: I mean using a "Button Device" trigger in Rule Machine, not a "Button" trigger. "Button Device" brings up more or less the old Button Controller UI, which scans the capabilities of your driver (at least for the first button device you choose) and only shows the appropriate options. Apparently, "Button" leaves you to your own devices (no pun intended)--you can choose doubleTapped, but it won't do anything (i.e., your rule actions will never run in that case) because the device doesn't support it (so the trigger would never occur).

That being said, all of the Pico drivers support "pushed," so if that's not working, that's a different story. You can troubleshoot this if you're interested--you should see something in your live logs when you push it. It's possible something was just wrong with the rule.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.