Lutron light seems to respond erratically within hubitat

I've had a Lutron dimmer switch that has worked fine within hubitat through the Lutron pro bridge, but within the last year or so a problem has developed. I've contacted Lutron and through their support I've been trying to narrow down the problem.

Right now, I'm leaning towards something wrong within Hubitat.

Here is what is going on.

When I control the dimmer via a physical switch, or the Lutron app, the light behaves normally. But, if I control it through Hubitat via the device page, a scene, or an Alexa command the light works for a while but then eventually doesn't set to the right setting. If I set the dimmer to 100%, everything will say that it's at 100% but it's definitely more like 30% or 40%. Then, when I turn the light off through Hubitat or a command it flashes once or a few times then turns off. When it's doing these things, if I control it through the Lutron app or the physical switch, I can turn the switch off and back on and then the switch functions as expected, almost like it has been reset. But when I go back into Hubitat and control it, eventually it develops the same problems and it doesn't work properly again. I have a second Lutron dimmer in my system that functions completely normal, no issues whatsoever.

Anyone have any idea what is happening? I've taken the dimmer out of the wall and checked all of the wiring. I've unpaired and paired the device. I've reset the device. No luck whatsoever.

Maybe it's just a broken switch.... But I don't hear of a lot of Lutron switches $hitting the bed. Maybe I'm just lucky.

I've got 30 of them and I have never seen one go bad once in production. I did have one go bad during installation but I might have caused that issue - and it was just plain dead. In my time on HE I don't recall seeing anything that resembles your symptoms - not that my recall is definitive. I can't remember what I had for breakfast.

What I'm trying to wrap my head around is it being an HE problem, especially if you have one that works just fine. All I can think is somehow HE thinks it has some capability it doesn't and that screws up the dimmer. If you look at the two device pages side by side are they configured identically? What about deleting the device and re-adding it from the integration?

Have you checked the "in use by" section of the device page to see if there's something else (a rule or something) that might be unknowingly interfering with the function of the switch? I've had that happen to me with other devices I thought were not working properly just to find out I'd set up some rule and forgotten about it.

1 Like

Hi @brad5

I've tried deleting the device in the Lutron app and then re-adding it. I was avoiding deleting it from Hubitat since then I would have to re-add it to all of the scenes and routines. But, maybe I should try that when I have some extra time.

I don't see any rules that would be causing a problem under the "in use by" section of the device. I compared the device page to the other Lutron dimmer in my house and everything looks the same besides the Device Name/ Integration ID's which should be different.

Disable the apps that it is in use by and see if the issue goes away. Any command send by Hubitat results from an action in one of the apps the Lutron dimmer is use in.

That's going to be interesting.... If i disable all of the apps then it's going to be me or my wife walking up to the physical switch for control which I've already concluded works fine that way.

Would you recommend disabling them all at once, or try each one, one at a time?

Disable them all.

If the dimmer works as expected, then enable them one at a time.

1 Like

I've disabled all of the apps that the light uses and controlled it from within the device page. At first I thought everything was fine, so I turned the Echo skill back on and immediately started to have problems, so I turned that off again and everything seemed to work again. Then tried to add a scene and it started to have issues again. So I turned that scene off again. I'm pretty sure that I have turned off all of the apps that uses the light, but after a while of playing with the light in the device page, eventually I'll have the problem where the light only goes up to a certain brightness level and then when I turn it on or off, I'll get a flash.

Even though I have turned off all of the scenes and groups that the device uses, some of them do not display as "disabled" next to them in the device page. Maybe that is a clue to what is going on?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.