Lutron Integration devices not being created


#1

I have 9 Lutron Picos and a dimmer all working without issues. When I went to add another Pico and another dimmer last night, the devices are not being created in the devices list. I can however see entries under the log viewer for Lutron Telnet if I press a button on one of them. My hub is a C-4 on version 2.06.112. Everything worked fine when I set up the first 10 devices a couple months ago. Anyone have any ideas on this?


#2

Shot in the dark...reboot the Lutron bridge?


#3

I assume you added them to the Lutron App on your phone, correct? Did you also go into the Hubitat Lutron Connect App and manually add the new devices there as well? They are not auto-discovered.


#4

Did that and also rebooted the Hubitat but no luck. I don't think it has anything to do with the Lutron bridge. Both the pico and the dimmer work fine in the Lutron app. I can also see them communicate with the correct ID numbers in the Hubitat log under the Lutron Telnet device. It's just that Hubitat is not creating the devices after I add them in the Lutron Integrator.


#5

Yup....same as I did to add the first 10 devices that are still working fine.


#6

Reach out to @bravenel. He may have seen this before.


#7

Thank you. I'll do that.


#8

I would also suggest looking at your past logs for any errors with the Lutron Integration app. You can also open live logging in another tab and open the Lutron app and click done to see if error happen.


#9

I had this happen once. i ended up deleting the lutron app and then re-adding everything. Luckily I only had a few devices in at that time.

I’ve seen one other user post with a similar issue in the past also. I think there is a bug there, but the other user did the same thing I did and the bug was never chased down.


#10

Which method do you use to add the devices in the Lutron Integration app in Hubitat?

Do you use the interactive, step-by-step method or the configuration list method?


#11

Thank you all for your advice. I heard back from support today and they confirmed this to be an issue but with only a small number of instances. It was recommended that I remove the Lutron Integration app and add everything back in. This has apparently been the fix before. Not ideal for certain but it's done now and everything worked correctly after reinstalling the Lutron Integration app.