Lutron + Alexa via Hubitat

I am trying to add my in-wall dimmer to Alexa via Hubitat (not the Lutron app) and have my Bridge Pro configured with the Lutron Integrator and can see and control my device via Hubitat, but Alexa will not find and add the dimmer even though I’ve updated the Amazon Echo Skill and selected the dimmer. With my other devices, they were found quickly.

Is there a step or prompt I’m missing somewhere?

IIRC (its been quite some time since I did this), you need to add the Lutron Skill as well to the Amazon Alexa app (at least that is my current setup). Also, not specific to Lutron devices, but sometimes, when devices are not automatically added to Alexa via the HE Amazon Echo Skill (it works most of the time), I found that if I went into the Alexa app and did a manual search or “add device” that it would then pick up the device. Also, make sure that you remember in the HE Amazon Echo Skill to not only hit update after adding the app, but to then hit “done”. Hope this helps.

No. Not necessary. All my Lutron dimmers are integrated with Alexa via Hubitat.

1 Like

OK, sorry. I stand corrected as its been quite some time since I have done this as I mentioned. Sorry to give out incorrect information. I just checked my Alexa app to see what skills I had enabled and it may have been a vestige of when I had Lutron devices integrated with Alexa prior to when I integrated it with HE a couple of years ago. I apologize for any misinformation.

Thanks for the quick insight. I did make sure to hit Update and then Done, but I think it was related to something else.

I modified the IP address in HE to a static route earlier and also reserved the IP in my router table, but was having trouble connecting to HE in my app after. I was able to access via direct IP to the static route I changed, though, so figured it was caching issue. I thought maybe this was related but not sure how. Found an unrelated post talking about static IP and changed HE back to DHCP after configuring the IP at the router and re-setup the Lutron Integrator then updated the Echo Skill and, boom.. that did the trick.

So, to confirm, one does not need to enable the Lutron skill in Amazon.

Still getting the hang of this (HE). So powerful and have barely scratched the surface from moving over from Wink.

1 Like

You may have connectivity issues doing this. Just do the reservation in the router, then press the reset button on the bottom of the hub with a toothpick or paperclip for 7 seconds. This will reset your NETWORK settings ONLY. This could be the problem with exposing stuff to Alexa.

2 Likes

When you are using a device that has its own skill with Alexa, you either use the native skill to control with Alexa or thru the Hubitat Alexa skill but not both. If you do both, you will have duplicate devices. Fortunately, when you open the duplicate devices in Alexa, it tells you which skill is being used to connect.

1 Like

There is a limit to the number of devices that Alexa will accept for one integration. Is it possible that you might be over that limit?

1 Like

Download the Hubitat app