Lots of rules broken after 2.3.4.119

I just updated to 2.3.4.118 and am seeing a lot of rules that say they're broken but they worked fine earlier today and there's nothing obviously wrong with them. Since I now seem to have 8 (that work but say broken), I'm curious if there's way to resolve this short of recreating them by hand. @bravenel - do I have any options here? Any idea why it says broken?

Here's one --





Does it clear up if you hit Update? Pretty clearly a false positive. It's now looking for removed devices.

I have four also broken...update does not resolve.




Summary




I've tried both update and run - neither cleared it up. It did correctly flag a few where I had broken conditions that were not in use but after removing those the rules still show broken.

OK, will track this down. These are false positives. If you don't see "**Broken ... **" in the rule itself, it isn't broken. In other words, it's a UI break.

Did you hit "Find broken rules" in Rule Machine?

I tried "Find broken rules" and it found "a lot" - I've not checked all of them but I know at least the majority (if not all) of my rules are fine since most run at least once a day and I haven't seen anything amiss.

edit: just counted the ones it flags and there are 51. I have 8 actually saying broken in the UI (and as noted above, as far as I know all actually work ok)

I did not.

They just showed up in the Apps List?

I have two hubs with RM rules. One updated no problem, the other has one broken rule. It appears with the --Broken-- tag without hitting the "Find broken rules".

Yes...went to look at my RM app list after seeing @rvrolyk's post, and the Broken notice was there.

Clearly broke something. This should not affect how the rules work. But, we'll pull this release and fix it.

Closing this topic for now. Will re-open once we put out the fix tomorrow.

6 Likes

This issue should be resolved by Release 2.3.4.119. If you have rules that became marked as Broken from 2.3.4.118, you may need to open them. Just opening them should clear that Broken mark unless the rule is actually broken.

4 Likes

All but one of my rules and button rules that were broken had the "Broken" tag removed automatically after installing .119. Didn't have to do anything.

One rule still showing broken. Going into it and choosing Update/Done did not resolve it.


(upload://u32KketfHmFpRo1vOvuGCMaIDKO.png)

Hmmm, sort of strange. Open the Actions page and see if you see anything there. If not, there are a couple of things I will want to see from App Status page...

Actions page looks normal to me:


What do you want from App Status?

From Application State, 'actions' and 'capabsfalse'. Also, as an experiment, try undisabling those two actions.

Undisabling the two actions and then updating/done the rule didn't help.

Actions and capabsfalse info below...



i also have one that shows broken that was not broken previously. it is in the trigger. unfortunately I dont remember what the first trigger was but know it was working a day ago after seeing this thread i pressed the check rules on ver .117 and all was fine.

thats not to say it is not really broken. but i dont know..

1 Like

Download the Hubitat app