Lost all Zwave devices: Settings/Zwave Details shows NO devices...What to do?

@danabw: Thank you.
@jtp10181 : THANK YOU SO MUCH. I think my Zwave network is back in business.

I followed your linked instructions, but have a bit of a different situation than the linked one. I'm wondering:

  1. I changed the Device Name (in addition to the Device Network ID) on all the Zwave devices listed on the restored Device page, but the Device Name field never appears in the pairing or swap process. Is it the Device Label I'm supposed to change? I think Device Label is what appears in both pairing & swap. Instead of entering the same text, I entered the label text with the suffix NEW in the pairing, and used that in the Device Swap.

  2. Once I've done the Device Swap, can I delete the old device by clicking "Remove Device" on the Device page?

  3. Also, either I've done something wrong, or I've discovered a bug, so tagging @bobbyD .
    As directed by @jtp10181 I started with renaming, resetting and then pairing my Z-Wave Locks. Then I did the device swap. All the apps except Lock Code Manager picked up the swap. Even though the Device Labeled "Lock xx NEW" lists Lock Code Manager on the "In Use By" apps, it would not recognize the codes. Upon investigation, I found that Lock Code Manager still had the original Device Label for each user. It has a dropdown with all the Locks so I just went to one user and deselected the original Device Label and selected the new "Lock xx NEW". HOWEVER that really messed things up. It won't take (persists at "Pending") and all the other users entirely disappeared.

I will need to do another restore because I have users whose codes I do not remember (I'll write them down somewhere outside of HE to avoid this issue in the future, but now I have this issue). I'm wondering how I get Lock Code Manager to recognize the device swap? Do I just set up a new instance of each user and copy their code?

1 Like

1 - Yeah if you have a label set that trumps the name. Only purpose for the name is so you can tell them apart in the swap apps and device list more easily. The DNI is the critical thing to fix.

2 - Yes delete the old device, double check the DNI to be sure it is the old entry.

3 - Lock Code manager gets very screwy with migrations and Swap Apps, I have helped a couple people fix that recently. Especially if you had lock code encryption enabled. You may not have done anything wrong.

@jtp10181 I would greatly appreciate if you can please point me to the appropriate threads or help me...

  1. Swap failed only in LCM; per above it deleted the users so that was a problem.
  2. I restored the old database again, and wrote down the user codes. Plan was to then delete the users and enter them new. LCM now won't delete the users; constant "job pending", even after a hub reboot.
  3. Renamed the users to append them with _OLD and created new users, then tried to enter their codes, but apparently LCM won't let more than one user have the same code.
  4. Tried to add an extra digit to the _OLD, but LCM won't remember it; constant "job pending" even after a hub reboot.
  5. Tried to change locks (that worked the first time) but it won't take.
  6. Tried to delete the entire LCM app, which worked. Then I added the app back, and all the previous users are there again linked to the _OLD lock....grrr

PS @bobbyD LCM is one of the apps where you have to click in the blank space to get to the next screen...

ETA: After MUCH messing around, I now have the two main users working with the main lock and the preferred (original) codes. One of them still has a "jobs- failed:1 in the brackets where it should say Always enabled, and the other has " , null" after the [Always enabled] brackets. They both think they are connected to 2 locks: the MainLock and the MainLock_OLD. No way to delete the MainLock_OLD. The other users won't need access for at least a few days, giving me time to figure this out.

For those following along, after the Z-wave on the HE died, the locks still worked. I presume this must be because somehow HE transmits the codes to the lock and they are stored in the lock. However, when I reset the Zwave radio, in order to get the lock paired with HE again, I had to reset the lock. This must have erased everything stored in the lock. That is when my real trouble began.

As an aside, do you have a clue as to the root cause?
It wasn't the power source, was it?

No idea. I've still got the HE plugged in to the adapter it came with, which I did per the above. Not changing anything until I a. get my household back to somewhat normal operations (ie lock codes work, etc) and b. sign up for the subscription thing.
Also, @bobbyD there is no info at www.hubitat.com about the subscription hub protect thing. I finally found it via this community, clicking Documentation, then Hub Protect. Seems like it might be helpful to have a link on the web home page for that.

Could now be a good time to upgrade hubs? :slight_smile:

No. Now is a good time to get my household back to normal operations ASAP. New hub would just delay that, and add variables.

1 Like

So all LCM really does is read the "lockCodes" attribute on any lock devices. Then to add/remove codes it just issues the commands to the devices for you.

If you already have all the user/codes jotted down, included the locks again, and did the swap (for any other apps) then I think the next thing to do is just delete the old devices so LCM wont see those codes anymore.

If LCM is still screwy delete the app and reinstall it. Should give you a clean slate with the old devices gone. Then just try adding one user back and see if it takes, if it does, add the rest back.

If you get stuck from there just stop and say where you are at. If you keep mashing on it, I will just lose track of what has been done and it makes it harder to recover.

Ok. I did that. I get this:
Select "Force Remove"?

Just to be the devil's advocate, the C7 z-wave radio crapped out for an unknown reason. Who's to say if or when it'll happen again?

However, I realize how ingrained this stuff can get in your life, and I don't even have smart locks, which, while convenient, seem to be problematic for some. So, roll the dice, get the C7 back up and running, get cloud backup and consider upgrade options later.

I'm pleasantly surprised it came back to life! :slight_smile:

1 Like

If you are getting the Force Remove option I think you are on the wrong device. That should only show if the DNI is linked to a paired device in the z-wave details list. That is why I said to double check with the DNI having _OLD in it, do not rely on the device names.

When you go to remove a device that is not linked to a paired Zigbee or Z-Wave device it should just remove and go away. The only prompt might be warning you if the device is still in use by any apps.

1 Like

I'm definitely removing the old device, and I don't think the DNI is linked to a paired device in the Z-wave details list (but I'm not totally sure).
This is the Z-wave details list, showing the new pairing of the lock:

This is from the Device details page. The one thing that confuses me is that it says the old one last connected at 4 something today, and it really should be sometime on 6/24, so I'm wondering if I got something messed up when I restored the database to get the Lock codes.

Is that the Force Remove Option? Both devices are definitely still linked to LCM. The swap worked with EVERYTHING except LCM. However, I can confirm that even though the new Lock device is now named in the rules. the rules involving it are not executing...

I'm ok with totally deleting both locks and restoring from my 6/24 backup, deleting LCM and then starting over by resetting the lock, etc. if that would help, but if there is a way to get the new lock device into rules, that would be nice.

The one with the _OLD DNI should be safe to force remove. There might have been a change in what triggers that prompt recently.

As for rules not working, if they depend on other z-wave devices that are not yet added back that might be causing an issue?

Selecting Force remove removed it, allowed me to properly set the lock in Lock Manager and caused the RM rule (that only involves the lock - it relocks it if left unlocked for more than x minutes) to start working again.


I'm slowly factory resetting and adding back my Zwave devices. I've found that Force Remove is required so far for every device.

The Inovelli switches worked great for factory reset, but once I re-added them, the old/new parent/child devices are mixed up. I've done the swap for the parent, but there is no option to swap the child devices, and the old child devices are still associated with rules/automations...

The other challenge has been plug in Jasco/GE wall outlets/dimmers. Cannot get them to pair again...

Sadly, Swap doesn't work for child devices, not supported. So those you have to change in the automations manually.

Thank you for letting me know. Going to start working on that now...
@danabw: Since the Parent/Child Old/New are mixed up, I first deleted the Old child device (which was Under the New Parent). Then I deleted the Old Parent. Unfortunately, that also deleted the new child device. So now the Inovelli dimmer has no child device. How do I solve for this?

1 Like

If the driver is well made, running configure should add the child devices back.

They must have changed something later in the beta. I tested a lot of add/removes for Long Range stuff during beta and had some issues with this dialog sequence, and I know for sure it was not asking for Force Remove on an unlinked device. Doesn't really matter either way though so I guess that's the new normal.

Try doing an exclude on them first, put hub into exclusion from z-wave details then start exclusion mode on the device. Hub should say unknown device excluded. That clears out the old node info on the device and lets you include again. If the exclude wont even work then possibly the device cannot reach the hub. Also be sure you start with the devices closer to the hub and build outwards, so any edge devices have options for hops to reach the hub reliably.

@jtp10181 @danabw @rlithgow1 @velvetfoot
Thank you so much, all of you. I'm happy to report that after the radio reset and following the instructions @jtp10181 provided, I've FINALLY got every device paired and working again and could not have done it without your help. @jtp10181 thank you for your patience, detailed instructions and answering all my questions!

A few observations from this process:

  1. Do NOT trust or believe the google AI results you get for how to factory reset or pair a device. These show up at the top of the search results, but I knew there was a possibility they could be wrong, so I continued down the search results looking for the original documentation for each of my devices. What shocked me was that almost ALL of the google AI search results on reset or pairing procedure were totally wrong. I would have thought a better average. This has taught me to NEVER trust those things.

  2. The lock was the most difficult device to get working again because of issues with Lock Code Manager. See above.

  3. Some devices just did not want to factory reset or re-pair and took multiple (ie 5-10 or more) attempts particularly one Jasco plug in outlet. The Jasco double plugs also got pretty confused - when I paired them again the new parent suddenly took on the old child devices (and vice versa). I had to delete the old parent (which deleted the new child devices), then delete the old child devices under the new parent, then configure the new parent in order to get it all working properly.

  4. Inovelli & Ultra Pro Switches, as well as anything made by Zooz were the easiest to reset and pair again. They most consistently worked exactly as per the written documentation.

  5. The swap procedure not being available for child devices was discouraging.

  6. After finishing resetting, pairing, then swapping all my devices, all of my rules except one work again. The non-compliant rule was the last one I had in RL, so that was a good excuse to rewrite it for RM, where it now works great.

  7. Some of my devices are in difficult to access locations, which made resetting & pairing again exponetially more difficult. This includes physically difficult (requires a tall ladder or crawling through the crawl space) and difficult due to annoying process, such as the Zen51's stuffed in an electrical box behind switches. I'd pay good money for devices intended for difficult to access locations that can somehow be reset or paired by power cycling from the electrical panel or some other remote way, as inevitably something will happen that will require me to access the devices again one day... As it is, I'm rethinking if I want to install any more Zen51's. Although I'm fine doing it now, the older I get the less I want to trust myself with turning off circuits and working inside J-boxes.

  8. I should have bought Hub Protect sooner. I have it now.


How does your z-wave details page look?

As far as I can tell, it looks great. Each device has it's own node, has a route, and each (except 2 that I would not expect to) have had a last message within the last 24 hours. All but one have their previous speed in the route column. So I think all is good...