Lock Code Question Marks

Having trouble seeing my codes in Hubitat. I added a Kwikset Lock 910 by z-wave and when I look at the Devices page for it, it shows four question marks for the codes. I tried adding codes in the Devices and LCM, and it does the same thing.
Does anyone know what to do to fix this?

Current States

  • battery : 80
  • codeChanged : added
  • lastCodeName : code #4
  • lock : locked
  • lockCodes : {"4":{"name":"code #4","code":"????"},
    "6":{"name":"code #6","code":"????"},
    "7":{"name":"code #7","code":"????"},
    "8":{"name":"code #8","code":"????"},
    "9":{"name":"code #9","code":"????"},
    "2":{"name":"code #2","code":"????"}}
  • maxCodes : 30

Do you have encryption turned on?

Screen Shot 2021-04-30 at 6.27.35 PM

2 Likes

When you added the lock, did it already have codes on it? If so, delete the codes and add them back using LCM or the lock's device page.

2 Likes

Now why didn't I think of that ? :smiley:

1 Like

The encryption is disabled. Should I enable it?

They did have codes when I added the lock. I tried a factory reset to delete them all but they didn't delete for some reason. When I try to do the LCM to delete the codes, it keeps saying the job is pending and then it fails. I'll try if the lock's devices page delete them. Thank you!

You may have to delete the codes from the locks keypad.

2 Likes

The Kwikset lock I have doesn't let me delete the codes. It wants me to add in a new code in the position that it has a code. But I'll try to work on the lock's device page to see if it deletes there.

1 Like

Do you have any advice on renaming the codes and adding the numeric code to my lock codes? It keeps showing question marks where the numbers of the code should be.
i.e. - "code":"????"}}

I'm afraid I don't. I had something similar happen to my Schlage lock when I migrated to Hubitat. The solution for me was to:

  1. exclude the lock from Hubitat
  2. delete all the codes using the lock's keypad
  3. factory reset the lock
  4. pair the lock back to hubitat. There were two code positions (slots 1 & 2 with ????)
  5. delete code slots 1 & 2 from the device page
  6. add codes using LCM (or the device page)
1 Like

Thank you for your prompt response. I will see what I can figure out. You've been a great help....

1 Like

I just got my Schlage Connect Z-wave lock connected yesterday. I paired the device as a generic Z-wave lock. I changed the device description to Schlage Z-wave lock. I turned on encryption. I installed the Lock Code Manager. I had already added a couple of personal codes to the lock manually. Once LCM was installed I asked it to download the installed codes from the lock. A few seconds later, my code table was prefilled. All I had to do was assign names to the codes. It worked brilliantly.

By the way, if you are using something like Actiontiles for Hubitat that can activate your Hubitat devices over the Internet, be sure you turn on passkey protection for the panels. That allows you to change the settings of any lock tiles to require use of the passkey to activate the lock. Otherwise, if someone hacks into your account, they could open your door lock from anywhere in the world. There might be a time when you might find it helpful to unlock the door when you are away to allow access to someone who does not have an authorized lock code, but you do not want just anyone to have that ability.

Download the Hubitat app