Local Dashboards do not remain updated on ANY devices, for more than a few minutes - websocket issue?

I have posted about this before, and I hope that's ok. I will continue to revisit this every few months until we figure it out. From what I have read this is a Hubitat problem and not a "me" problem, but I am happy to entertain any and all ideas.

I have multiple dashboards that I've built in Hubitat. I have 2 Samsung galaxy tab tablets wall mounted in my house. I also have 2 different iPhones using a dashboard. The Android tablets are utilizing fully kiosk browser and all power saving / hibernate / app suspend features are turned OFF. The iPhones are using Safari to load the dashboards.

Across all devices I get the same failure: the dashboards stop synchronizing after a few minutes to an hour if I'm lucky (it's random). The green check REMAINS GREEN - no red exclamation mark to say it isn't updating. In order to simplify this, I can also tell you that I have a simple clock running on the dashboards and even that clock stops updating the time. Finally, this dashboard has my security camera feeds running into it as images that get a mjpeg feed. The camera feeds ALWAYS REMAIN UP TO DATE on all devices. This is why I think this is a Hubitat issue. It proves that the devices are remaining connected to my network and are receiving data - the cameras stay live!

Any time that I do a manual page refresh, I get an updated dashboard, which as I said, remains updating for a few minutes to hours before it stops updating.

This is all running local, no cloud dashboards.

Can anyone give me any advice on how to diagnose and troubleshoot this? I would be happy to fix this for the community at large because I am certain this issue is not just me. I think dashboard updates are broken for the majority of users.

Thank you as always for the great help!

I can't claim any expertise that might shed some light on this, but if nothing else am curious about what the issue may be.

  • Do you have any "fancy" networking setup like VLANs or use of a Guest network for IoT devices, etc?
  • If we focus on the Samsung devices, have you tried ruling out Fully Kiosk and running the dashboards in a regular browser session (not sure if that is possible, haven't used Fully Kiosk myself)?
  • Have you tried opening the dashboards on a PC / Laptop to see if you experience the same behaviour?

I'll admit it is odd, and not something I have seen as consistently as what you are describing. So I expect there is something different in your setup, but cannot be sure what it is.

This happens to me too. Any local dashboard open for more than a few minutes stops responding. Get the little red exclamation.

Then of course, on remote dashboards, my hub variable tiles don't update when values change... I made a post about it and several people confirmed the issue, but there didn't seem to be any hint that anybody was looking into that issue either...

1 Like

I have the same problem using Fully Kiosk. Fortunately, Fully Kiosk has an API and I can issue refresh commands to it and do it about every 2 minutes via Rule Machine. However I have found doing that causes an annoying memory leak in the Amazon Fire Tablet browser - which then needs to be rebooted once a week, but it works.

Hi, great questions!

I do have VLANs and Guest / IoT networks, but the Hubitat, tablets, and our cell phones are all on the same internal network together. I use a UniFi Dream Machine.

I have tried a regular browser session (Chrome) and have the same behavior as with Fully Kiosk (which I believe is using the same Chromium engine under the hood).

Yes, on my laptop I get the same behavior opening the same dashboard on the same internal network. This is why I truly believe this is a Hubitat bug and would happy to be proven wrong!

I do have the API set to refresh every couple minutes, but it is very annoying if the refresh happens while we are using the tablet to do something such as arm / disarm HSM. Good advice though - thanks.


I have been troubleshooting this in my spare time for YEARS now. I have now determined that whenever I reset the ACCESS TOKEN the dashboard will properly update on my tablets for at least 24 hours before the problem resurfaces and updates stop. If I reset fully kiosk browser, reboot my tablet, delete all cache on it - NONE of this works. Only resetting the access token. I will say it for the millionth time - this is a hubitat bug that no one wants to investigate and fix. Help please?


Does anyone from the Hubitat team actually care about bugfixes and making your product actually work as advertised?

I now can tell you that the dashboard update issue is definitely a hubitat bug. Every night my hubitat reboots at 4AM and the dashboards stop updating. As soon as I create a new token, they update perfectly for the entire 24 hours --- does anyone want to troubleshoot and fix it? Hello? Crickets?

This will get fixed in the upcoming 2.3.6 firmware update.


Download the Hubitat app