Linux and Hubitat

I'm running a Parrot OS (Debian Linux) desktop and want to know if there is a Hubitat app available for this environment?

The Hubitat app is for smartphones... So I do not think directly. If you replicated an Android environment on the desktop you could run the app in that instance.


Hubitat’s admin interface and dashboards are accessible from any web browser.

1 Like

I'm aware of that but the website is not secure. I was hoping that there was a workaround.

I’m able to connect to my hub with https.

1 Like

Yes, although it looks like the little green checkmark in the upper right corner is constantly cycling with a red exclamation point, so something’s presumably not functioning quite as intended. I can interact with the dashboard though (e.g. I pushed a button tile and it activated a lighting scene).

So I’ve noticed that when going through the dashboards tab on the lefthand side menu, clicking on the local dashboards doesn’t actually load them (even without the secure connection to the page). The cloud dashboards can load from that page though. No idea what’s up with that, but I basically never load my dashboards that way (I typically use the mobile app or direct dashboard links), so it’s not an issue for me.

Yes I understand that. In my last post I was referring to the behavior you mentioned re: local dashboards not loading. When using the dashboards menu in the web GUI (from a desktop), I see that behavior whether or not I have tried to connect securely to the hub.

I said that that doesn’t bother me because I rarely connect to my dashboards that way.

The screenshot I posted above happens to be from a mobile browser. But it’s a browser window nonetheless, and it connected to the hub with https. A direct dashboard link in the same mobile browser also connected securely, with the caveat I mentioned above.

I don’t usually try to connect with https, because personally I don’t care that much about a secured connection within my own LAN.

But to take that screenshot above, all I did was add an “s” at the beginning of the address, i.e. https://hubitat.local.

The padlock isn’t green, but that’s just because the hub’s certificate is self-signed (as far as I know). But again, it’s a web server on my LAN, so I don’t really care that much.

I don’t even know exactly what that means :wink:.

On one of my windows desktops, I have added the hub’s certificate to the trusted certs store, but that’s just to try to avoid getting warnings in a browser window when loading the page securely.

Edit: I don’t think that would apply to the mobile safari window screenshot I posted above.

The web interface is the only admin interface. If you use the app to access it, all you're doing is wrapping the webpage inside the app. As far as I can can see (using the latest iOS build; perhaps this is different on Android), it's just HTTP there, too. If you use Remote Admin and are accessing your hub (e.g., from outside your network) that way, then you would get HTTPS, as all of Hubitat's cloud connections through their own servers use. The hub is capable of serving either locally, as was pondered above.

In other words, for this purpose, you might as well just use the website. :slight_smile: You can upload your own SSL certificate if you want, too, though the feature is a bit hidden (and I don't need to say that it would be hard to revert if something gets messed up, but that possibility exists, too): Use my own SSL cert on Hubitat? - #38 by gopher.ny. I'm not sure what people who use this option do: use the default hubitat.local hostname, or run everything through a reverse proxy that only does HTTPS? When I'm on my own network, this isn't a priority for me, and if I'm not, I'm VPNed in anyway, so I haven't tried...