Linptech presence sensors stopped reporting June 5 and June 9

They both installed and worked perfectly at first. I just discovered that they are no longer reporting motion and lux. I rebuilt the Zigbee network three times but still no reports of motion or lux.

This is one of those very frustrating situations where I changed nothing but the devices stopped working.

I am using the built-in driver with everything set to default.

Any suggestions?

Mine (just have 1) just stops working once in a while too -- I have to power cycle it, then it's OK until next time.

It's frustrating, but it's not like these things are finely honed, exquisitely engineered devices - they're just cheapo Tuya, so we have to temper expectations accordingly.

The moment anything better comes along, I look forward to getting rid of mine.


Every few days mine drops off the hub. This weekend I plugged it into a smart outlet and cycle the power daily. Motion reports but Lux stopped several weeks ago which isn’t a big deal for me.

Aqara FP2 is much better, though I have mine integrated locally with HA and events come into HE.


It is what it is. I have few of these sensors and yes, once every couple months power must be recycled for restoring functionality.

I have I think six of these in place now. One of them would drop off randomly and like the others report here, a power cycle would fix it. I put it on a smart plug and I power cycle it once a week at 4am and zero problems since.

1 Like

i have all my zigbee extenders ( and just lumped in the radar with it as it was also troublesome) monitored by a rule and when one drops offline i have them on zigbee usb switches i manually take care of it.. i guess i could automate that. but this seems sufficient for me. Same as others drops off maybe once every month or two

How does this ‘reports’ action work in RM?

Thats just the normal "attribute value" but since it is a non std attribute value it is reached in rule machine through the custom attribute option.

Ah, OK - this ‘notPresentCounter’ is a custom attribute which value increases with each failed time check period.

I don’t use it in my drivers, because updating periodically the notPresentCounter attribute also updates the ‘lastActivity’ property of the device, making the Device Activity Check app unusable.


I only run device act. check like every 12 hours . It is more critical if extenders drop off so i want to know sooner. Thus this rule. It was too senitive at just a count of one as it can be transient such as when you reboot hub etc. This rule works well and has had no false positives. Also the 4-1 driver i am using for the radar is your driver. Did i modify it or how did the attribute get there?

I added this rule when it was really needed when the c8 first came out and zigbee was so flaky and stuff kept dropping off left and right.


This rule will not work with the 4 In 1 driver (substituted now by the Tuya Zigbee mmWave Sensors driver. …

There you can fine-tune the criteria for the healthStatus attribute offline. In the ‘Advanced Options’ you can decrease the time period used to check for any activity from the device. Three consecutive failures (equals ‘ notPresentCounter’ = 3) will trigger healthStatus offline.

Agree - that’s why I always check for 3 consecutive failures.


"Have you tried turning it off and turning it on again?"

No. Wait ...

That worked!

New plan!

1 Like

I have mine on a smart plug too just in case I need to reboot it. Right now I just reboot it manually via a dashboard tile, but I am thinking of automating it with a rule that will automatically power cycle it if there has been no lux report in more than 30 minutes.

1 Like

I just put them on Sonoff Zigbee smart plugs. Will restart every Monday and Friday whether they need it or not.

1 Like