Linking two Elevation hubs that are in separate buildings

I don't know a lot about networking. Should I be connecting the workshop hub directly to the line coming to the shop instead of plugging it into the router there? I could add a switch box if needed.

The two hubs need to be able the see each other on the network. If you can ping the shop hub from the house and ping the house hub from the shop you should be OK network wise. If you can't, you will need to rearrange the network to suit.


Getting closer. Got HubConnect installed and I now see the workshop hub on the master hub device list. Don't see the switch that I shared. Have to head back down to the workshop to look at it. At least I'm getting some exercise today walking between the two.


Haven't figured it out so far. Can see the hub not the shared switch.

Here's the 'picture' I have in my head regarding your system.....

Hub in your Home, configured as Server. That requires the installation of 4 code modules, minimum... HubConnect Server + HubConnect Server Instance + HubConnect Remote Hub (a driver) + HubConnect Switch (also a driver)

Hub is in your Workshop configured as Remote. That requires the installation of 2 code modules, minimum... HubConnect Remote Client + HubConnect Remote Hub (a driver)

The "Real Switch" is a device on your Workshop Hub and is using a built-in driver.

You've gone into the HubConnect Remote Client on your Workshop Hub and clicked Select Devices to Synchronize to Server and found your "real switch". You've clicked Done a couple times and noted that the HubConnect Switch driver needs to be installed on the server BEFORE clicking Done.

If you didn't install the HubConnect Switch Universal driver on your server.. no worries.. just do that and go back to your Workshop hub and dive down into selecting the Switch again.. you don't have to Do anything, but as you click Done again to get out, the final Done will send the entire list of selected devices to the Server and the server will build the virtual switch on your Server hub.

I was reading the information posted today about the new HubConnect version here

That lead me to installing the HubConnect switch driver in the master hub. I didn't do that before because the instructions implied it was optional. I'm not at home so I remoted into the house computer to do the install. I can't remote into the workshop laptop so wasn't able to do the next step but I will when I get home.

Hopefully this will resolve the issue, then I can continue migrating the devices there over to Hubitat.

Thanks for all the help.

The "optional" part is referring to the quantity of Universal drivers you install... as well as when. There's no "don't do it" option. :smiley:

You have the option of doing it now (in the order of instructions) or later.. 'never' isn't an option :slight_smile:

I knew that never was not an option. It just said I'd be prompted to do it. I know better now. Can't wait to get home and push the done button.

Getting closer. I can now see the switch in the master hub device list. But when I try to turn it on, it does nothing. I added the switch to a dashboard and when I click it, it shows an hourglass and does nothing.

I went to the workshop computer and can control the switch either through a dashboard or through the device properties. And on the dashboard from the master hub the icon changes to show the state of the switch. There is a slight delay though.

The state also changes in the dashboard if I manually work the switch.

I removed the switch from the workshop computer dashboard and no change in the issue.

Still not working correctly. Checked everything up and down. Added a new switch to the workshop hub and went through the process of sharing it with the master hub, including installing HubConnect Pocket Socket driver as instructed in the workshop hub before clicking "Done". The new switch (a GE outdoor plug in module) shows up on the master hub but still can't operate it.

I guess my next step is to install an ethernet switch in the line between the house and the workshop router so I can plug the workshop Hubitat hub into the switch and maybe get it on the same subnet.

The release notes for HubConnect seem to say this isn't necessary but worth a try.

From the release notes:

  • Flexible oAuth endpoints; Hubs do not need to be on the same LAN or even same location.
  • Remote hubs can be located anywhere with an internet connection.

The next question will be, can I just change the IP address for the workshop hub in the master hub settings or do I need to start over again?

Assuming that's an accurate description of what you did... it's wrong.

If the Real Device is on your Workshop hub, it needs a "real Driver" -- and probably has one.

The 'other hub' (home in your case) needs a driver too, but there's no real device there. The workshop hub (aka Remote) will send a message to your home hub (aka Server) saying "here's the list of devices here, that are needed there" and Server will attempt to build a virtual device using virtual drivers (aka HubConnect Universal drivers.)

Put the HubConnect Universal drivers on the Server hub for all REAL devices in the workshop.

Put the HubConnect Universal drivers on the REMOTE hub for all REAL devices in the home.

It doesn't hurt to have all drivers on all hubs.. tedious, but harmless :smiley: (in other words, no need to delete drivers, just keep them up to date.)

Acutally, I stated that wrong. I installed the HubConnect Pocket Socket driver on the server hub in the house as instructed. Not on the remote hub in the workshop. It also wanted the HubConnect Switch driver but that was already installed on the server hub for the previous wall switch I had in the workshop hub.

I'm at work but set up my computers at home so I could remote into them. I installed the two HubConnect drivers on the remote system. Still doesn't work.

I'll go through and install all the HubConnect drivers on both later.

Doesn't hurt.

Again, HubConnect will tell you what it needs:


You will see that list of necessary drivers on each hub that has real devices you're sending over the connection. It says to put those drivers on the Server if you are seeing it on a Remote and it says to put them on the Remote, if you're seeing on the Server.

Seems like everything is setup properly and it just doesn't work.

I'm going to try inserting the switch box in there and see if it comes up on the same subnet. Hopefully I can just change the IP address in the HubConnect server for the remote hub and not have to start over.

You are using http (oAuth) correct?


From the documentation:
"- Flexible oAuth endpoints; Hubs do not need to be on the same LAN or even same location."

choosing Hubitat (LAN) as the Type will cause the Hubs to communicate via Hubitat's Cloud.


Yes, using oAuth with Hubitat (LAN). Just like you show. Should I change it to Hubitat (Internet)?

Here's the latest. I removed the workshop devices from the master hub. I put the ethernet switch in my shop and got the workshop hub on the same subnet as the master hub. Updated the IP address for the workshop hub in the hubconnect server and then reshared the devices from the workshop. They show up with the correct IP but still don't function from the master.

I can now go to the workshop hub on the same computer as the master hub and work the devices from the dashboard or properties there. When I turn them on in a workshop dashboard, they show up as on in the master dashboard.

Of course now I think I've caused myself another issue as it will be hard to add new devices in the workshop because I don't think I can get my laptop to attach to the house wifi from down there. I may have to switch the cabling back which means starting over. But until I can figure out this HubConnect issue, I'm not going to add more devices there.

It sounds like to me that this is what you want.

From what I read, you have two networks, one at the house and one at the workshop. Each of them have their own internet service and are not connected in any other way. The only way to connect them with HibConnect is via the cloud and you want to use the type “Hubitat (Internet)” for that. LAN won’t work unless you have an interconnection between the two locations

I only have one internet service. I had to add a wifi router to my workshop because it's a metal building too far from my house to use a wifi extender. I have ethernet cable going from the house to the workshop. It is connected to a powerline adapter in my garage that I use to connect my solar inverter to my house modem/router.

I started out with the workshop hubitat hub connected to a port in workshop wifi router but this caused it to be on a different subnet. Now that it's connected before the wifi router it is on the same subnet as the master hubitat hub in the house.

Ok, I misunderstood, Hubitat LAN should work for you if it is on the same subnet.