Linear Iris garage door opener GD00Z-1 problems

Hi, just got my whole system up and running about aonth ago , switching from Smartthings. So far so good, and I really appreciate the help of everyone on here. I'm having problems with my Iris branded GD00Z-1 garage door opener. It always shows as an "unknown" status in the dashboard. I've tried and tried to "refresh" the door status in the Hubitat devices tab, but it never changes. It also shows the contact sensor as closed, which is accurate.

I've tried power cycling the opener, and pushing the little black link button on the opener.

It's super annoying, since I have an automation to disarm the house, unlock a door, open the garage and turn the garage lights on. Everything works great, just no opening of the door.

I really really don't want to delete the device and start over. I remember I used to have this issue occasionally with ST, but power cycling the device seemed to get it back in sync.

Anyone have any ideas?

Check if SecurePairingComplete. If not, you need to remove and pair again. Hub must be very close to the controller to pair properly.

Just checked, it shows it as complete. It was working pretty reliably for almost a month, and it was great. Now it seems that it's out of sync with what it thinks the garage door's status actually is, and doesn't work.

Open/close garage door manually using garage door opener or button, see if status will update. If not, you need to remove controller from Hubitat and pair it back . I used to have issues with mine very often, until I place z-wave dimmer near by, that is working as a repeater now.

I vaguely remember back on Smartthings, there was a way to re-sync the contact sensor to the door other than manually opening the door with the wall button, but I can't find it anymore. The official pdf documents don't show anything either.

ya just open close manually a few times and it should sync.. otherwise check battery in door sensor it may be dead

Unfortunately that hasn't worked for me at all for the past week.

Figured it out, found an archived post on the Smartthings forum. No idea why this isn't in the official documentation I have with the opener.

Remove the tilt sensor, hold the link button on the opener for about 5 seconds or until it beeps. Hold the button on the back of the tilt sensor, and change orientation until the opener beeps in confirmation.

Works perfect now!


False alarm, it now just says "closed" for status, and doesn't change. I'll try a new battery in the tilt sensor, re-pair the sensor with the door and try again when I get time.

Ordered a new 2032 Energizer lithium battery, and will report back. I thought I replaced it recently, and the "battery life" in Hubitat for the sensor shows 100%, but I don't think that's accurate at all.

i am not sure what you are looking at the tilt sensor for the gdz doors are not a device that you see in hubitat..

From what I understand, the tilt/contact sensor is only communicating with the door, and not directly to Hubitat.

Either way, the door either will sometimes show it stuck at "opening", "unknown", or "closing".

yes thats what i meant not sure where you got the number that the sensor was at 100% battery,. you dont see that in hubitat.

You're correct, I was looking at the 100% status of my door lock directly under the garage door.

I tested the battery with my multimeter, and it's 2.7v, so maybe the sensor is picky and needs a fresh one.