Linear/GoControl Garage Opener not including

Hi guys... Adding another one of my devices I ran into issues with my Linear/GoControl GD00Z-4 Garage Door Opener. I have tried every flavor to include it and it simply won't work.

The device is 'found' as a Generic Z-Wave Garage Door Opener. After a few seconds 'initializing', I'm able to give it a name and save it. Once that happens, if I go to Devices, it shows Close and Open Commands, but no Current State. If I click on either Open or Close, nothing happens and the log shows 'Error' null.

I have done several factory resets on the hardware, rebooted HE, excluded, re-include it, remove it (exclusion fails most of the time), force-remove it (HE always says the Hub is in inclusion mode when trying to remove), etc. - Still no go.

This was a perfectly working unit up until I removed it from my previous automation hub (VeraPlus) this morning to migrate it to HE.

I have put HE in Zwave Secure Mode in 'Locks/Garage Door' mode as well as 'All Secure Zwave' and tried the inclusion process under both settings to no avail.

Any insight on how to get this device working properly? Many thanks in advance for your help!!!

Have you tried getting the hub close to the device? Garage doors and locks sometimes, because they're secure, need to be close to the hub to pair correctly.

Hi, I’ve been able to get the hub within 15 feet of the device with same unsuccessful results! :disappointed:

I’ll try to bring it closer and will report outcome.

Thank you....

Success!!! I was able to secure-pair the device by getting the hub within 3 feet of it. It's working with no issues now!

@Ryan780 - Thanks!

1 Like

No problem. Glad I could help.

I was having the same problem, came here, read this solution and brought the device into the house, literally less than a foot from the hub..

I cannot get it to include securely, no matter the secure join setting in Z-Wave settings I use.

Anyone else have thoughts here? About ready to chuck this thing in the trash!

I paired two of these in place, about 20 feet from the hub located inside the house, no issues, but I have repeaters and a solid zwave mesh.

I've paired mine successfully in place as well with a decent mesh. When it all fails the reset reliably seems to fix it. I use the instructions here

1 Like

FINALLY got mine paired securely.. not sure if is that I held the tilt sensor and repaired it with the control unit before inclusion, but I hope I never have to remove this thing from my Z-Wave network...

What a pain in the backside....:angry:

So, I'm wondering if I have a bad hardware unit for this thing... as mentioned in my previous post, it took about 20 attempts to get it to pair securely to my Z-wave mesh.

And now, less than 48 hours later, it appears that this thing is dead - it won't respond to open/close commands, and isn't updating the door or contact state - I re-paired the tilt sensor with the main unit, and it claims it did it with a confirmation beep, but I still get absolutely no response with this unit.

I've tried re-syncing it by operating the garage door manually, but no dice... any other thoughts before I try ordering a replacement?


@guywmartin Try a recycle of power to the main unit. Give it 10 sec.+. I used to have one of these and I was always recycling power. I finally put another z-wave (or zigbee) outlet between the wall transformer and the main garage outlet to be able to recycle power to it.

Also I had to include it to the hub in the same room as the hub, after including the tilt sensor to the opener first. Then install it in the garage.

Hrm.. no dice - power cycled with 1 minute wait twice, device is still not responding....

I guess I'll have to try some new hardware and see if that's the issue... grrr.

Thanks for the tips.

Also remember that after you get the device into HE you need to run the garage door from your normal garage controller so the GoLinear device picks up the tilt.

Yup, already did that multiple times.. I should been clearer - this was working fine for about 48 hours... it no longer responds to any commands or registers the tilt sensor...

I would suspect that you don't have a solid Zwave mesh. I paired my Linear GDO in place 2 hops from the hub. If you have devices able to repeat the Zwave signal you shouldn't have a device go dead. Have a good analytical look at where powered Zwave devices are in relation to the GDO and the HE hub. Mentally draw a straight line between the devices and imagine what is in the way of a low power radio signal.
Add additional powered Zwave Plus devices to strengthen the mesh. You may be able to re-positioning plugin powered devices being mindful of where your other devices are.

That was my first thought too, but, I've been working with @bobbyD on this, and I have at least four mains-powered repeating devices in the line of sight path to the hub from the GDO.

This also worked flawlessly for 48 hours.

This does make me think I should try another Z-wave repair though....

That Controller is great or it's horrible. Those two wires that you run into your Motor?? If it senses anything on them, it goes 100% stupid and mimics a brick. Don't confuse this with "lost ZWave" although I don't know how to tell the difference,

ZWave mesh is critical including a Beaming device along the way.

When I was migrating mine from ST to HE 18 months ago or more, I had a terrible experience. Wouldn't join securely inches away or yards away. I finally left it and moved on to migrating everything else. I had the exact same problem with my Lock. Neither would Join Securely so I just left it and migrated everything else.

I got to the last device, a battery powered Aeon Recessed Door sensor. It worked fine, of course BUT since I was standing there, right next to the door lock, I gave it one more try. Joined instantly. I was so excited I tried the GDO next. Joined instantly and the Hub was in it's normal place. These clearly were now using Beamers to Join over the mesh. It was several hours.. like most of a day.. between first tries and the last.


Interesting - I was able to join it (finally) from inches away, installed it, and it was working flawlessly for about 48 hours.. I did run a Z-wave repair after testing the install to make sure I had a solid Z-wave mesh for the rest of my devices... not sure if that affected it or not, but I'll leave it for a couple of days and see if anything changes.

Thanks for the insights.

Well, @csteele, you were likely correct, as I just tested this a few minutes ago (after being away from the house for 4 days with the Z-Wave network quiet while I was gone).

It appears to have found the beaming device closest to it. Thanks for the insight.

1 Like

Yes, it does work if you "pair" it correctly with the control unit.

Amazon (dot) com /gp/product/B01MYMMSD7/

This is the exact unit I bought this week and it works perfectly with the Linear Z-wave Garage Door Opener.