Limit activation for time period inconsistent

What I mean by this is that if you go into Means to activate lights > activate lights options > limit activations under these conditions

For everything there, if selected, it presents you with an option that says "Do not activate when the following is true". For example, selecting switch on will present you with a box that says "Don't activate when the following switches are on". Selecting mode will present you with a box saying "Don't activate when mode is".

Selecting between two times presents you with a start time and end time and says "Activate only between" It's the opposite of all the others. I spent way to much time troubleshooting why a light was coming on when it shouldn't before I realized this. I had expected it to be "Do not activate between the following times". Obviously... this is my fault for not reading the text. But I wanted to point out that it's inconsistent with the other options in the limit activation area.


I was just about to post the same issue. I see no one responded to your post so lets see if @bravenel has an answer.

It seems wrong to me as well.

In my use case I currently have the limit activation for my bathroom lights set to mode is night. This works great. When I get up in the mornings, or if I have to get up in the middle of the night, I don't want the lights coming on, we have a night light. This morning for the first time in a long time I slept in. I didn't get up till almost 9:00AM. My wife had gotten up before me and the house had switched to home mode. So when I got up and walked in the bathroom the lights came on.

So I thought I would see if I could set a time window as well. Under limit activation along with mode there is between two times. See below.

Like @waterboysh mentions any other option you select says limit activation except for between two times it says only activate. Maybe this is due to the nature of the event driven system, but I don't understand why an event can't be setup at the start time to disable the RL rule and then re-enable at the stop time. Maybe it's just a typo and should say limit activation but from the above post it sounds like it works as advertised.

I haven't had a chance to try it out yet. In my case I happen to notice the wording before I went through the same scenario as waterboysh above. I could see, however, how it could easily be missed. At the very least there needs to be something that draws your attention to the fact it's not like the other options. In the last screenshot I originally had the limit set from 5:00AM to 10:00am, before I noticed the wording.

1 Like

I pointed this out a while ago. IIRC, @bravenel said it had to stay the same orientation ("only between") to allow for Motion Lighting imports. I agree it's annoying, however.


Ok thanks I did a search and the post above was the first one I found. Still would be a good idea to have some type of warning as it could easily be missed.

1 Like

OK, I see why you're not happy with this. But, the phrase "Limit Activation under these conditions" does not state what the conditions are. Each condition in the pull down states was the limitation is. Would it help if the pull down said "To only between two times"?

Yeah I think that would be better to have the limitation obvious when you select it. Less chance of someone missing it.


I think it would make it more obvious if the drop down menu text were changed, yeah. I probably would have noticed it right away.