Lights coming on at 5% instead of 100%

I have a rule that turns off selected lights when we leave, and to turn back on when we arrive. The rule has been working great for quite some time.

The past few days when we arrive, the lights are on but very dim, and HE states the levels are 5%. Yesterday I changed ‘Preset Level’ and ‘Set Level’ to 100% and saved the preferences.
We just got home and the bulbs are dim and HE states they are 5%.

I have another rule that opens the shades and turns these lights on when a button is pressed. This rule also sets the bulbs to 5%

The bulbs are IKEA 1000 lumen and the driver is ‘Advanced Zigbee Bulb’

  • endpointId: 01
  • application: 11
  • firmwareMT: 117C-2101-23094631
  • inClusters: 0000,0003,0004,0005,0006,0008,0B05,1000
  • manufacturer: IKEA of Sweden
  • model: TRADFRI bulb E26 W opal 1000lm
  • outClusters: 0005,0019,0020,1000
  • softwareBuild: 2.3.094

Should I add actions for these bulbs so they turn on then set level to 100%?

I assumed on was on.

What changed?

Those are commands, not preferences. Nothing saves; it just (sends a command to try to) set the device to the specified state when you run the command.

Prestaging in general is also a bit odd and doesn't play well with all devices. In many cases it is best to find another way to do your automation instead.

As for the rest, it's not clear to me exactly what you are doing or what is going wrong or where, so sharing a screenshot or specific description of those automations might help clear things up if the above explanation doesn't account for what you're seeing.

Was editing my post and you replied.

Only lights 1, 2, 3, and 4 are dim.

I don't see anything there setting the level, just an action that should run a command to turn on the devices. With most devices (some odd ones may have a configuration option that can make them do something else...), this would just turn them back on to their last level. If you always want them to come on at a specific level in this rule, I would use the "Set dimmers" action instead of the "Turn switches on/off" action.

The alternative if you only want to use "On" for some reason would be to pre-stage the desired level beforehand (every time), but again, this does not work well for many devices and is not something I would recommend starting with if you can avoid it.


Thanks. I will change the command from ‘On’ to ‘Set Level’

Again, changed in the past few days to require this?

Nothing would have changed unless you did something, but even if you updated your hub to the latest platform version (guessing that's what you might mean?), I'm not aware of any changes that would impact this.

I don't know what changed the initial level to 5% or 10%, but the way the rule is written they would would always come on at that level from now on without a Set Dimmer command.

I haven’t fiddled with HE in weeks other than the firmware update.

Something else I noticed, not only those 4 bulbs were coming on at 5% but the light above the sink was the same way. It is also an IKEA bulb, but a GU10 whereas the others are E26

All 5 bulbs use the same ‘Advanced Zigbee Bulb’ driver.

Now they are all set to dim instead of on.


I must have a Poltergeist. At approximately 2:20 this morning, lights 1, 2, 3, 4, and the sink light all turned on and were set to 5%.

There are no automations in Google because HE does that.

There are no hunches nor routines in Alexa. Again HE does that.

For now I have disabled both Google Home and the Alexa skill in the HE app list.

Nothing that screenshot points to Alexa or Google as a culprit. The "Triggered Apps" section just means apps that are listening for that event, not what app sent a command to possibly cause it (assuming that is what you saw). To blame them for sure, you'd need a command. These also show up in Events, contrary to its name, but you'd need to look for entries that start with "command-" or have "command" in the "Type" column. That will show you what did it--if it was anything on the hub.

For bulbs in particular, also check groups or activators the individual device may participate in.

If there are no commands to be found, the change must be coming from outside the hub. Even Alexa Or Google would ultimately show a command on the hub, so this would be things like a "physical" manipulation of the device, a manufacturer app or integration outside Hubitat, etc.

There are 2 ways to turn on a light. use the on/off method or use the dim # method.

if you use the on/off method the light will come on at the last known dim setting. so fi the light dim setting was set to 100% then shut off and you turn the light on with the on command it will go to 100%. instead use the dim 50% if you want it to always come on at that setting. you can use dim 0 or off to turn off the light.