Lighting Group Speed

I go to sleep late... Too late...
I've heard that the hub does a lot of maintenance things at 3AM which might occupy it but I usually hit goodnight around 2AM.

Keeping this up there as it's still an issue and not just my issue:

Not sure if there are clues in this:

Yea I don't know if my issue has something to do with a maintenance schedule occurring when I happen to go to bed, or if a 3rd part app is running rampant on my hub, or if there is some legitimate issue with multiple commands out of a single trigger.

If I get to the bottom of it with support I'll update here.

Thanks. I documented with 4 of the same bulbs. Time turning on/off bulbs one a time were fine. As soon as I started putting multiple bulbs/switches into a got slower and slower. Something is very different with turning off a large amount of switches/bulbs. ST did this even though it was through the cloud much much faster than HE can.

1 Like

@dan.t -> from another thread:

I'm trying to keep one thread and add all the other threads with the same problem. I don't know if the "multiple" events per page is related or not but I'm seeing that too.

Plus keeping this thread at the top.

1 Like


I think I'm experiencing a compound issue that wouldn't be an issue if the box had more horsepower.

  1. I typically issue Goodnight at 2AM, which is when Hubitat starts running it's maintenance.

  2. If my crappy Samsung button doesn't work because it's stuck in sleep mode I whip out my phone and issue Goodnight from Apple Homekit via Homebridge, which causes all of my devices to update their status which takes a toll on Hubitat as it is.

I would mark this as solved for me if I could push the maintenance back to 4AM.

For me it has nothing to do with the maintenance window, I can replicate the delay at any time during the day or night


For me it isn't the maintenance window either. I have removed most 3rd party apps that do not support my devices and nothing has changed.



just as a quick update, I think I figured out my problem by accident.....
I think that my problem came down to my Z-Wave mesh....

I was still trying to figure out what is going on and was wondering if the switches have the wrong neighbors.
So I installed OZWCP in a Linux environment on Windows (Windows Linux Subsystem). I bought an additonal USB Zwave adapter some time ago to do firmware updates and that adapter is tied into my HE as a device. On startup, OZWCP went to town and updated all the routing information on my Zwave devices.
After that initial startup, my response times for my routines were very fast, as fast as they had never been with HE, and no more double or triple events!
It appears as the devices had some old or wrong routing information that then somehow compounded....

I already ran a few "Repair Z-Wave" from HE over the last couple of days/weeks that never had that same result as running OZWCP.

I am still wondering though why the HE Repair Z-Wave did not have the same effect as the OZWCP....

A different approach could be to do factory resets on the devices and then link them again to HE. I would recommend to do a clean "exclude" first with HE and then doing a full factory reset on the devices that are acting up. That might clear the problem for you....

1 Like

So maybe getting somewhere. I just built this Zwave network from the inside out on the HE hub when I got it and migrated from ST. So the devices were all working OK there. I also did what you said. I did a full reset on them so that it left ghost devices in ST and then added completely new to Hubitat. So all resets. I have since ran zwave repairs in HE....but what does OZWCP do that Zwave repair doesn't?? I'm all for getting this speed thing fixed!! Any info you can provide on OZWCP is greatly appreciated...

This is the ultimate question I don't think we should be needing to run 3rd party software as a resolution. If we can develop a pattern though. HE repair doesn't help, but OZWCP does..then I think we could make a good case for something being amiss in the HE repair.

I wish I would know all the details of OZWCP, I just stumbled over it as I found out that this tools lets you see which device has which other devices as neighbors. I didn't expect it to run a full route update on my existing network. Don't get me wrong, I am glad it did as I am sitting grinning over the speed of my routines now.
I am going to see if I can find some more information on OZWCP. I basically came to OZWCP via this thread: Z wave mesh frozen completely and have about 10 minutes of experience with it...

Some OZWCP info here:

You can also look at ZenSys Tools:

OZWCP is the first tool I go to because it has drop down menus with words. An icon with a garter belt just isn't mnemonic enough. :slight_smile:

I have this and will be the first to admit I was afraid of doing more damage than good but not 100% understanding what I was doing in there. Does anyone know of a decent writeup of how to check the health/mesh in Zensys?

I couldn't get OZWCP to install at all in Ubuntu. Ugh directions are not very clear.

My "instructions" are simply the list of packages I needed to get Debian working. I know nothing about Ubuntu, not even how to spell it right :slight_smile:

I used

is there a similar tool for Ubuntu?

1 Like

Bump. I am on the latest release and experience the same issue. Groups and scenes take up to 5 minutes to execute. Reboots and resets don't help. People have been mentioning this in multiple threads and has been a long time issue.

With each new release we get new (obscure) drivers added, but where are the real fixes for long time problems?

Could you show the group you are having a problem with, and what kind of devices these are. This is not normal behavior at all. Groups are typically very quick to turn on/off.

I have about 8 different groups. I only use them to turn devices off as part of a goodnight, away. etc. type modes.

My devices in these groups are lutron switches and directly connected hue lights (no hue hub). Those are the only two types of lighting devices I use.

I don't nest groups in groups. If I control the device as a single light (after a motion event) it responds normally. However when changing modes and my RM4 triggers a group "off" event, is where I see a very long delay. 5 minutes might be exaggerated, but 2 minutes is not.

I switched all my groups to v2.1 groups. I don't suspect the lutron hub because single light events work fine.

I do use hubconnect.

Can't take screenshots right now, but hope I have given some useful info

If HubConnect is in the middle of this, you're going to have to do some work on the logs to see what is actually going on. As I said, it would not be a normal circumstance for a Group turning off some lights to take very long at all. You might also try isolating the groups to specific types of devices, to see if each of Lutron and Hue work as expected from a Group.

1 Like