Lightify Gateway API integration

That’s what I had to do, and glad I did. Way less expensive than replacing the lamps and keeps control local. They work great and I have several other devices on that hub that play well with the OSRAM lamps. I have found the the Iris V2 sensors get along with them well.

This has not been my expierence, I have has issues pairing other devices (non bulbs) in general with osrams on line, never completing initiazalation is the signature of this problem.

Maybe I am lucky, but I have about 7 or 8 v2 motion sensors and a Sylvania 2 button dimmer paired to that same hub and have never had an issue. They are all fairly close in range and I have some v1 and v2 outlets in that mix. I have motion lighting running on that hub too, with those sensors and some lamps. Also some ST buttons. V1 iris buttons and motion would pair but would drop off.

Fair enough, but I could pick up a used hue bridge for about 30 bucks. Got any gently used HE hubs lying around to sell at a discount? :laughing:

1 Like

Just to explain legacy silos. The Internet demonstrates the powerful idea of relationships between end points independent of whatever is in the middle using a generic and shared infrastructure over any distance.

Silos like IEEE-1934, Zigbee etc. entangle all the smarts between the particular signaling, the need for a repeater per protocol per community, assumptions about timing and distance etc.

I've written about this in my column and elsewhere. It's why IEEE-1934 died.

What do you use to link your multiple hubs together?

I use HubConnect. I started with the built in hub link app, but the need for more attributes and 2-way communication between hubs sold me on HubConnect. It also connects to my homebridge install on a raspberry pi so that I can use HomeKit. This ups the WAF...

1 Like

Some code I chucked together before hub connect came out.

Hey guys,

I've set up a whole bunch of outdoor Sylvania Lightify stuff in the past couple of weeks, all without issue. I usually paired the lights with the Hubitat, then took them outside and put them up, but this last strip I set up in-place. I turned them on and gave it a couple of minutes, then was able to control everything. All of the lights are generic Zigbee RGBW bulbs.

So far I've put up a couple of sets of garden spots and garden accents, with extensions, plus an outdoor flex light. Inside for now, I've set up 4 BR30 lights and 4 regular bulbs, and another outdoor flex. These all work just fine through the Hubitat, and it easily recognized and paired with each.

I've also got a set if Hue outdoor spots, an outdoor flood, two of the outdoor path lights, and a Hue outdoor strip. The Hue cost 3-5 times what the Sylvania did, but I can control them with things like Light DJ, or the Hue Labs Halloween app. I can do things with them I cannot with the Sylvania, but the Sylvania, with Hubitat, can be configured to do some pretty cool things too.

We're going to have the coolest Halloween ever.

Mike, can you explain the necessity for this? Are you referring to the issues you saw when the Lightify 4-button controller (switch) was on the same network as other zigbee bulbs? If so, are you suggesting using a separate HE hub to place all Lightify Bulbs on it alone and then control them via button controllers paired to another HE hub via HubController?

I and others have observed zigbee sensor and actuators not being able to send and or receive commands in situations where these devices are on the same network as osram, and to a lesser extent older hue bulbs.
This may only effect dense networks, as some customers don't have any issues at all.
I have observed this in the lab with a small number of devices.
I don't think there's any way to predict this behaviour, and there's not really a need to worry about it unless your setup experiences zigbee reliability issues after the addition of osrams.

OK, thanks. I will give them a try with one hub and see what happens.

Mike when you say "osrams", for clarity, which model(s) in particular cause this behavior and the need for a second hub?

Im not aware and certainly don't have a model black list.

Hi everyone,

Just to let you know that @adamkempenich has released an Alpha version of a local integration with the Lightify Hub.

Check it out here:
https://community.hubitat.com/t/release-alpha-lightify-gateway-integration-0-20

2 Likes

Haha wow, this thread is funny to look back at. I remember thinking 'who the heck is going to write that driver for us?' when I'd first gotten my hub :laughing:

7 Likes

Does anyone have issues with this link? It says it's not there or private when I click on it.

The discussion thread for the lightify gateway local integration currently is:

It seems that @adamkempenich changes the title every time he releases a new version... When the title changes, the link changes...

A more permanent link would be to his github repo

...

It’s really strange. My MagicHome thread’s URL has worked since day 0, and I’ve changed that one a lot. I’ll remove the version from the title and call it good if I can’t figure out perma linking. No more confusion... until it goes to beta lol.

FYI - Lightify Cloud is shutting down next year. Obviously this integration is local but worth a read to understand any implications:

1 Like